Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Trying to edit the "login" text.

edited October 2006 in Vanilla 1.0 Help
Not the people file but rather the "Not signed in (Sign In)" text. Which file would I need to edit it?
«1

Comments

  • Options
    Try the english/definitions.php file.
  • Options
    Nope didn't find anything there.
  • Options
    Well that's where it is?
  • Options
    Lines 221 and 222.
  • Options
    I have integrated (to some extent) Wordpress and Vanilla. I took Mark's option one, re which sign-in to use. This has meant deleting vanilla's sign-in, people.php file. OK, that's easy to do. But at the top right corner of vanilla there is a sign-in text/link. I thought it would be easy enough to go in to the definitions.php file and delete the unwanted text. but if you look now at http://multitrackers.com/community/ you will see that there are still brackets left up there in the top right (where the text/link used to be). Any ideas? Maybe I should not be deleting that text at all - and instead changing the url to link to the wordpress sign-in?
  • Options
    edited October 2006
    Well, since I see you have already customized the CSS, you can be rid of it via CSS rather easily:
    #Session { position: absolute; top: 10px; right: 15px; color: #FFF; }
    Change to:
    #Session { display: none; }

    as far as changing the link... will have to check and get back to you
  • Options
    edited October 2006
    thanks, wall! OK, I won't delete the text yet - in case it's maybe best to change the link instead. I don't even know where to start looking for the link. BTW - tis annoying that vanilla looks crappy in explorer and fine in firefox (re the css changes I made last week to push down the buttons at the top). I can't figure why the results shouldn't look the same in both browsers. :(
  • Options
    Try setting $Configuration['SIGNIN_URL'] to the wordpress log in page in your /conf/settings.php. I don't think it would already be in that file.

    And you will have to undo the changes in the language file :-)

    As far as the CSS bug... ick. Will play with that a bit.
  • Options
    Just on the way out here to store, Wall. Thanks for the help. You ROCK! Gonna do some tweaking when I get home again.
  • Options
    OK, whats happening with the CSS, is #Header h1 has height in IE even though it is empty. Firefox sees that it is empty and closes out the space.

    Add height: 0; in #Header h1 and you are set. Tested with IE 7, so make sure it is OK in IE 6.
  • Options
    Thanks Wall. The page now looks the same in explorer as it does in firefox. Many thanks! I'm still in a jam tho regarding the login issue. I only noticed an issue there now (nothing to do with the changes you mentioned in settings.php). I was happily thinking there now that I was home and dry. I had changed settings to enable me to now login via that top right hand link in vanilla, via the wordpress login page. But despite that login working, and me logging in using my admin account details, i was then unable to get to settings/extensions. I tried logging in and out....but still not able to get to my settings in vanilla. I don't know what fixed the problem - but I undeleted the people.php file and reset vanilla's login to it's original login url, and now everything seems to worked fine (ie I can log in to my vanilla settings) I dunno what the issue is. But I notice that even after logging out of vanilla, I am still logged in to wordpress. There is a lot more to this integration thingie than meets the eye, methinks. I reckon I'll try maybe deleting the wordpress login, and use vanilla's login instead (ie deploy Mark's WordpressIntegration extension for logging in) I will report back.
  • Options
    deployed Mark's extension as mentioned above (WordpressIntegration) And in signing up for membership, sure enough (as expected) I am logged immediately in as a member of vanilla. But then when I go over to the wordpress part of my site, I am not logged in there. :(
  • Options
    edited October 2006
    ah, this must be a clue when i try to log-in to the above new member account (ie in above post), via the wordpress log-in page, I am told *You do not have sufficient permissions to access this page.* argh.
  • Options
    what about:
    #Session {display: none; visibility: hidden;}
  • Options
    If you're about modding things, then why not just make a custom themes/menu.php and delete the following (or add your own login linkage)?:
    echo '<div id="Session">'; if ($this->Context->Session->UserID > 0) { echo str_replace('//1', $this->Context->Session->User->Name, $this->Context->GetDefinition('SignedInAsX')).' (<a href="'.$this->Context->Configuration['SIGNOUT_URL'].'">'.$this->Context->GetDefinition('SignOut').'</a>)'; } else { echo $this->Context->GetDefinition('NotSignedIn').' (<a href="'.AppendUrlParameters($this->Context->Configuration['SIGNIN_URL'], 'ReturnUrl='.GetRequestUri()).'">'.$this->Context->GetDefinition('SignIn').'</a>)'; } echo '</div>';
    Anyone with the web developer extension can "un"-hide the login html.

    (Then again I suppose anyone with knowledge of Vanilla could straight out type the people.php URL...)
  • Options
    thanks dinoboff and pbear for your posts. I just walked away from it in dismay a few hours ago and am looking back again at it now. I don't havce much knowledge of these things and it is very evident when things don't go as planned. I cannot get successfully logged in..........ie log in and able to successfully use both vanilla and wordpress. eg I tried to log in there under my admin account in wordpress and tho it says I am logge din, it just shows a space or a dot where my 'admin' name shoudl be. yes i can go and change all the admin stuff in th ebackground...........but when i go to post in wordpress it posts as an anonymous. eg see http://multitrackers.com/2006/10/16/john-gets-his-free-bus-pass/ Success tho when i go over to my vanilla section of the site, i am logged in as admin and can post and change settings. So to conclude, if i log in via the wordpress sign-in, i have the above issues re wordpress........tho over on vanilla all is fine. I am pretty depressed. pbear, would your custom theme be the business?
  • Options
    Mmmm... it won't help you with the universal login problem. It was just to get rid of the "sign in" code. :( Extensions seem to be able to know when you're logged in. I'd look in some of those for a clue if the main WP/Vanilla isn't getting you anywhere.
  • Options
    edited October 2006
    thanks pbear. I have the site now running for 2 or 3 days. I think the issue was linked to when I tried to introduce wordpress plugins. At that point all hell seemed to break loose. The key problem coming up was when I clicked on links eg to login (i use wordpress's login) or go to various parts of the site, I was confronted with alternating possibilities ie either http://myhomesite.com/login.php OR http://www.myhomesite.com/login.php (note the with and without *www* in the urls. I am ignorant of such things, but after googling, i suspect there is an issue on my host server....htaccess issue? I ended up getting a plugin for wordpress that enforces use of one or the other. ie i choose to enforce clicks to be directed to the *www* version of my pages. Maybe Mark or others in here recommend that I redirect instead to the *www* version? The enforced redirect plugin is maybe not the best fix.....I have seen wordpress users talk of the best fix is to amend the htaccess file. But I am unversed in how to change such a file.
  • Options
    edited October 2006
    I forgot to add, there is another little issue that is disrupting things. Any newcomers coming to my site, see the discussion forum as empty. It is only when they login (via wordpress login which I use for the site) that they see there are actually threads in the forum. And yes, as on my other sites, i have vanilla set up to allow non-members to browse the forums etc. It must be something to do with the integrated wodpress and vanilla database. I wish I knew what to do to fix it. Newomers won't sign up for a forum which they think is lifeless. http://www.multitrackers.com/community
  • Options
    It might be something to do with the Unauthenticated role. I cant think quite what but it's probably worth looking at.
This discussion has been closed.