Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Local testing for an existing forum

edited September 2006 in Vanilla 1.0 Help
Is there a way (there probably is, but I'm not aware of it) to transfer a public board onto my EasyPHP server for Win?

I have tried to make a database and install a fresh copy of Vanilla, then I have imported the database from the live board and the local copy chokes on it. As I said I'm sure there is a way to do this, I'm just not aware of it. Can anyone offer a step-by-step instructions on this because I'm really not that experienced with serverside stuff. PS, I'm using phpmyadmin.

Comments

  • Options
    Do you have problem to import the database, or it is vanilla that has a problem with the imported database?
  • Options
    Vanilla has the problem, it spits out this error:

    Error Message
    The connection to the database failed:
    Affected Elements
    MySQL.OpenConnection();

    The error occurred on or near: Access denied for user 'root'@'localhost' (using password: YES)
  • Options
    MarkMark Vanilla Staff
    Make sure that there is a password on your root user. If not, and you don't want one, create a new mysql user and make that one have a password. Also make sure that user has full access to the vanilla database.

    Then make sure that your conf/database.php has the correct connection parameters for your mysql.
  • Options
    Make sure that there is a password on your root user. If not, and you don't want one, create a new mysql user and make that one have a password. Also make sure that user has full access to the vanilla database.
    This did the trick, Thanks!
  • Options
    I have one more question I can't seem to find an answer for.

    I have enabled mod_rewrite for my local testing server (EasyPHP) but I have another problem with relative paths. All the paths that start with a "/" (a slash) render broken because for some reason the "/" is considered root of the server (my C:/www dir) and not http://localhost/mysitesdir. Does anyone know where is this set so it calculates relative paths from the site's directory and not from server root? Or am I missing something big time?
  • Options
    I think the procedure for extracting a live WP database would be the same for a Vanilla database in order to install it locally. Check out this procedure by podz. The key is editing the sql file to replace all of your url references to localhost.
  • Options
    edited September 2006
    @DraganBabic: check conf/settings.php especially $Configuration['WEB_ROOT'] = '/mysitesdir/'
  • Options
    @ Dinoboff:
    I think it is an issue on my EasyPHP install (or every EasyPHP install).
  • Options
    From what I've read .. mod_rewrite isn't compatible with windows installations... all windows server packages ... have you considered double booting with Ubuntu?
  • Options
    edited September 2006
    I just remembered that I had this problem, too. I don't know if it is in podz's instructions, but I had to modify the httpd.conf in the apache/conf folder. I removed the # sign from:

    #LoadModule rewrite_module modules/mod_rewrite.so

    At the top of this file it talks about the backslash. I was just comparing my current httpd.conf file with an original copy I have. At least on my computer, I have a lot of changes in mine. I don't remember making these changes though. It does look like all references to "/xampp/cgi-bin" have been changed to the exact path "d:/Program Files/xampp/cgi-bin" and so on. And my current file size is 20KB compared to the original size of 60KB.
  • Options
    I use easyphp and don't have this issue.
  • Options
    Sorry, I didn't see the easyphp.
  • Options
    I have fiddled wit httpd.conf quite a bit, but this just won't work. Mod_rewrite is working fine though after I enabled it.
This discussion has been closed.