Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

I changed to a VPS and got "page not found"

I recently moved over my forum into a VPS w/ cPanel. I could not say further details because my provider did all the migration stuff. What I haven't noticed is the some of the settings or plugin settings like "feed discussion plus" returns an error such as "page not found" when I tried to click its settings.

Another thing, when I tried to go over to mydomain.com/dba/counts (https://kindtechgroup.net/forum/dba/counts) - it returns nothing. Sometimes returns a 404 or just refreshes the page.

I already cleared my cache folder but it didn't work.

Did you guys have experienced this kind of error? Please let me know. Thanks

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Clearing cache would have been my first guess...

    Check the line RewriteBase in your .htaccess file. Since you are running your forum in a sub folder, it should read RewriteBase /forum

  • Please enlighten me. I'm not a developer.
    Below is my .htaccess file

    Original

    If you modify this file then change the above line to: # Modified


    RewriteEngine On

    ####
    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forumforum)
    ####
    #RewriteBase /forum
    
    # Make sure that / doesn't try to go to index.php without a rewrite :)
    DirectoryIndex disabled
    
    ####
    # Deny access to certain directories that SHOULD NOT be exposed.
    ####
    RewriteRule (^|/)\.git - [L,R=403]
    RewriteRule ^cache/ - [L,R=403]
    RewriteRule ^cgi-bin/ - [L,R=403]
    RewriteRule ^uploads/import/ - [L,R=403]
    RewriteRule ^vendor/ - [L,R=403]
    
    ####
    # Prevent access to any php script by redirecting the request to /index.php
    # You can add an exception by adding another RewriteCond after this one.
    # Example: RewriteCond %{REQUEST_URI} !^/yourscriptname.php$
    # You can comment out this section if it causes you problems.
    # This is just a nice to have for security purposes.
    ####
    RewriteCond %{REQUEST_URI} !/index.php$
    RewriteRule (.+\.php) [E=X_REWRITE:1,E=X_PATH_INFO:/$1,L]
    
    ####
    # Redirect any non existing file/directory to /index.php
    ####
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule (.*) index.php [E=X_REWRITE:1,E=X_PATH_INFO:/$1,L]
    
    ####
    # Add the proper X_REWRITE server variable for rewritten requests.
    ####
    RewriteCond %{ENV:REDIRECT_X_REWRITE} .+
    RewriteCond %{ENV:REDIRECT_X_PATH_INFO} (.+)
    RewriteRule ^index\.php - [E=X_REWRITE:1,E=!REDIRECT_X_REWRITE,E=X_PATH_INFO:%1,E=!REDIRECT_X_PATH_INFO,L]
    



    Header set Cache-Control "max-age=315360000"
    Header set Expires "31 December 2037 23:59:59 GMT"

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    As an example, the # at the start of line 6 means that line is commented out - not processed.

    IF your Vanilla files are in a sub-folder called forum, then that line should be uncommented by removing the #

    mauwiks
  • Thanks! Will see it through

  • Same. It returns page not found to some settings like security in the dashboard

  • Can I disable the .htaccess file and reset a new one?

  • I've seen an error_log within my subdirectory. PM Sent @whu606 @R_J

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    The error reads like that:

    PHP Fatal error: Uncaught Exception: Requires POST in /public_html/forum/applications/dashboard/controllers/class.profilecontroller.php

    Most if not all of the settings require that you use the http POST method, not GET, to interact with them, that's the technical background.

    If you simply click on those links, everything is okay, but if you open them in a new browser window/tab, the action will fail with the above error.

Sign In or Register to comment.