Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Buggered my forum, sorted it with help :)

edited September 2006 in Vanilla 1.0 Help
Ok, I'm quite new to all this so feel free to treat me as such, basically I tried upgrading from v1 to 1.0.1 and made a mess. How I'm sure you're asking and I'm not sure myself, I was really tired and uploaded the wrong files and then have had no luck since. I did make a copy of my folder before making any changes though so I still have the settings files etc. I think what I'd like to do now is just install a fresh 1.0.1 and try to import the old settings and comments if this is possible, I'm not really too sure. If anyone can give me a pointer to where somebody's done something similar or a quick word of advice I'd be extremely grateful, Alec


  • Have you tried deleting all the new files, re-downloading them from lussumo, and re-uploading them? When you say 'buggered', what exactly happens?
  • Sorry about the delay, had to go out quickly. I'll try redownloading them from Lussomo and reuploading, keepin the conf and ext folders. By buggered I get this message: Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log. Thanks
  • I tried reuploading freshly downloaded files and still the same problem.
  • So if you upload the full folderset into a blank folder on your server and browse to it you get that error?
  • Try to delete .htaccess. It shouldn't be there except if you use mod_rewrite
  • I deleted .htaccess and it came up all funky, I'll grab a screenshot or post a link in a min. I'm just uploading into a blank folder now but hopefully wont get that error I'll report back in a sec.
  • Ok, on the original space where I've added the 1.0.1 files on top of the conf and extensions it looks like I've lost the table structure, its just text. You can see at With the fresh folder I had the same message, deleted .htaccess and its came up with the 1.0.1 setup as hoped.
  • Log in and activate a theme/style.
  • Wow! It's fixed! Thanks a lot guys I had some serious worries about that, I'm going to use a testforum to monkey around with from now on! Cheers, Alec
This discussion has been closed.