HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Vanilla API v2 on vanilla 2.8 [RESOLVED]

GentleGentle New
edited February 2019 in Vanilla 2.0 - 2.8

I receive

Errors                                           Hide
 
Parser error on line 17
end of the stream or a document separator is expected

Unable to render this definition

The provided definition does not specify a valid version field.

Please indicate a valid Swagger or OpenAPI version field. Supported version fields are swagger: "2.0" and those that match openapi: 3.0.n (for example, openapi: 3.0.0).

Anyone know how to resolve this error? I'm trying to search for api v2 but I don't find anything related to errors that match the output.

Comments

  • charrondevcharrondev Developer Lead (PHP, JS) Montreal Vanilla Staff

    What/where are you looking an seeing this error?

  • That would be at dashboard->settings-> Technical -> API v2.

    link https://domain/index.php?p=/settings/swagger

  • My bad. I just realized I'm using a rewrite for wordpress. Correcting the rewrite fixed this error. Apologies.

    charrondev
  • charrondevcharrondev Developer Lead (PHP, JS) Montreal Vanilla Staff
    edited February 2019

    Just to confirm, you got your re-write working properly right? The url should now be just https://domain.com/settings/swagger.

    Glad it's working for you now though. The API docs are actually served through the /api/v2/openapi/v2 endpoint, so if you can't see the docs the API won't be working for you!

    We also have a reference on our public documentation, but the in-dashboard one will always be more accurate to your installation.


  • Ummmm I'm having the same issue. So how did you solve it?

Sign In or Register to comment.