Migrate from VB 5.5.1 to Vanilla

Hi all,

Our forum has been using VB since 2008 but since the upgrade to VB5 we have had a lot of issues. It's a very small rare disease based forum but nonetheless important for our users.

Because we are tired of VB we would prefer to migrate to Vanilla but we don't know if it would be a fairly easy process.

We are using PHP 7.3.2 and MySQL 5.6.34

If anyone has advice let us know. All help is appreciated :)

Thanks!

Comments

  • You can use Vanilla Porter to migrate your forum to Vanilla.

    https://docs.vanillaforums.com/developer/importing/

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

    • Vanilla APP » Learn more «
    • iOS & Android App for Vanilla - White label app for your forum
  • Yes, but it seems that there are issues because of PHP 7.x

    https://open.vanillaforums.com/discussion/36921/vanilla-porter-version-2-4-with-php-7-x

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    For production, the current version, 2.8, is not ready for PHP 7.3

    For Porter, if I remember correctly, the error was in the creation. You wouldn't need to use your production site to create the porter file, and then it should work fine on your production site.

  • So we just need to wait a few more weeks for Vanilla 2.8 to be ready for PHP 7.3?

    I don't understand what you mean with; "You wouldn't need to use your production site to create the porter file, and then it should work fine on your production site." because porter is on version 2.4 and not 2.8?

    English is not my native language :)

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Only a dev could say how soon Vanilla 3.0 will be out.

    What I meant was: I think you could use Porter on a machine that was on a lower version of PHP, and then just move the zip file produced to your server.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    The porter should be able to work with PHP 7.x since October 2018. But the version you can download here doesn't seem to be the most recent version...

    To make your first steps quickly, get the files from GitHub and build the importer script by yourself:



  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    The porter should run fine with PHP 7.x. It looks like we haven’t pushed an update here in some time. In the meantime go get it from the github repo. I’ll update here when after I upload the latest version to the adding directory.

  • Just for future reference, where can people find the latest version,if they dont look on Github? thanks

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff
    edited March 27

    Github will always have the latest version. Sometimes developers who aren’t accustomed to doing open source releases will not even be aware of the release process, so we forget to update the addon.

    Every single addon used by Vanilla Forums employees and on our infrastructure are directly from Github source. The addon directory here is intended for people that don’t know or care to work with git.

Sign In or Register to comment.