Plugins not show in dashboard - Vanilla 2.8

TheWallTheWall New
edited April 12 in Vanilla 2.8 Help

Hello everyone, I downloaded Vanilla 2 month ago and started to look at code. I still learn php, so I don't need someone to do the job for me, I want to do everything myself.

I don't edit core files, just use plugins and apps. Some plugins don't work, but the biggest problem is some plugins don't show in dashboard at all. What can cause this problem, caching is empty and everything other works fine. Some plugins that not show at all: Nilla Blog, Articles, Vote, Pole, Dyslexia and more. Earlier version of nilla blog show up, but when click on settings just show blue line at bottom. Plugins/Apps are in different folders so it's also not about that.

And for the end, is this editor available in vanilla? Rich editor don't work for me, when it's turned on field for typing is blank.

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    This editor is the Rich Editor. If you experience any problems, you should take a look at the JavaScript console of your browser to check for any errors.

    If plugins do not show up check the following:

    • Is the /cache/addon.php outdated? Simply delete it once you have added a new plugin to the folder, it doesn't hurt
    • Is the plugin in the correct folder? The path to the plugin should always be /plugin/some-name/class.the-plugin.php
    • Is the plugins file name, the class name and the folder name correct? The folder name must exactly match the key from the PluginInfo/addon.json (see the documentation for more explanation on that). Some old plugins are named "default.php" and some of the classes defined in the plugins do not end with "Plugin". All plugins classes must be named "class SomethingPlugin" and the file name should be either SomethingPlugin.php or class.something.plugin.php
    • A plugin might have a RequiredApplication key. If in doubt try to delete that, delete /cache/addon.json afterwards and retry it

    If all of that does not help give the name of the plugin and we will take a closer look on it.


    HAPPY CODING! 🚀


  • TheWallTheWall New
    edited April 12

    @R_J thanks on your answer, everything is in folder where belong, cache folder empty after plugin upload. Problem is that happen with so many different plugins, I named some of them in OP.

    Some plugins not showing at all:

    Rate Plugin

    Countdown

    App not show: Blog

    Same app show but not work: 1.8.1 ; 1.8.2

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Showing but now working is a different problem. Let's try to fix one problem after the other.


    I've just recently worked on the rating plugin and therefore I know that it showed up in my environment.

    From looking at the NillaBlog I cannot see any reason why it shouldn't show up. But it is a plugin, not an application.

    The Countdown would need a change in the plugins file from class CountdownTimer extends Gdn_Plugin { to class CountdownTimerPlugin extends Gdn_Plugin {


    Please make sure that the /cache/addon.php is not read protected and it is really deleted before you re-visit the list of plugins. Afterwards it should be there again.

    Make sure your /conf/config.php is writable, but I assume that would have caused different problems.

    If all that doesn't help and you are in a development environment, please change the line ini_set('display_errors', 0); in index.php to ini_set('display_errors', 1);

    Afterwards you will see a lot of warnings at the bottom of the page and they can give a hint why those plugins do not show up


  • I changed ini_set few min ago to check errors. I tried on localhost, it's deleted before I reload plugins page. Showing but not working is something different, I will check it after I found what cause show problem. It's not just one plugin, and if it work at your server and not at mine, there must be some error. I will check and answer later what I found.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Maybe the web server doesn't have access rights to the new plugin folders?

    What about a html caching problem? Take a look at a newly created /cache/addons.php and try to find the plugins in there.


  • TheWallTheWall New
    edited April 12

    Some plugins work, so it's not about permissions. I also changed to 777 just to be sure.

    Plugins that not show in dashboard, also not show in /cache/addon.php

Sign In or Register to comment.