Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.

Getting this permission errors after installing Vanilla with docker

See this below

anyone ran into this or have any suggestions?


Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Well, there are three folders that must be readable and writable so that you can install vanilla. Guess which one?

    Try giving them permission 755, if that doesn't work try 775


    chris2kus
  • no, i get that. However, after i tried that, i get this error.


    chmod: cannot access '/srv/vanilla-repositories/vanilla/conf': No such file or directory

    which doesnt tell me much, so i am wondering if there is someone that ran into this and what did they do about it?

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Sorry, my first answer sounded more snotty than it should.

    It's all about file permissions. Your server must be able to read and write to that folders. If they do not exist, your initial unpacking of the zip file failed. If changing their file permissions fails you might have to run this command with higher permissions, e.g. sudo chmod...


  • Hi, thank you. There is another error that i am getting which I am wondering you if you had ran over it?


  • @R_J i tried both 755 and 775 and i am still getting that error, what do you suggest?

  • @R_J does it make a difference if I am running this through Docker?

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    I have no experience with docker. Worst case would be to give them 777 which for local testings is okay.


  • ShadowdareShadowdare Moderator
    edited April 23

    Are you using this vanilla-docker image?

    For the MySQL timestamp issue, your DB container probably has to be modified to fix that with an argument, environment variable, or config file passed in to the DB container. I'm not sure if this image includes the DB container or if you're meant to run it in a separate image.

    For the folder permissions issue, the user configured for the php container probably needs to be the same user that the folders are chowned to in the mounted volume on the host. Are you running Docker on Windows, Mac, or Linux?

    I've used Docker for other containers before, but not with this image. @charrondev might know how to fix this.

    Add Pages to Vanilla with the Basic Pages app

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    That docker image is not really production ready. I've been working on a production ready docker image for Vanilla (with the intent to ship it directly with Vanilla), but other responsibilities having been taking most of my time.

    If you're trying to run that docker image on linux you'll likely have some issues with file system permissions. I've run into them myself, but don't remember exactly what I did to get it all to line up.

Sign In or Register to comment.