Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.

Some questions about Vanilla

Hi I'm about to start a new forum and I would really love to try Vanilla but I need some help and advises.. first, I really need a credits/currency plugin and a shop one too which I already found on the plugins page, the marketplace and the karma bank, but I already tested on the latest version of vanilla and didnt work for me so I was wondering if anyone knew about any other plugins that could help me, even if its paid or if I could install an older version of vanilla maybe?

Also wanted to ask how is vanilla's community, cause I've found some tutorials and things but all are from 5, 8 years ago. Well, thanks guys, I hope anyone can help me

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    You should under no circumstances consider to use an old version of Vanilla. Every new version comes with security fixes that you surely shouldn't miss.

    The plugins that you already found are the plugins that I would have thought of, too. But they have been developed for older versions and therefore they might not be functional any more. But the changes between the versions since then have been small and therefore it should be easier to fix them, than to develop something completely new.

    I would advice to contact the authors of the plugins and ask them a) if they plan to update their plugins or b) if you can hire them to do so. If you tell them your exact requirements, they should be able to judge if their plugin is suitable for your needs.


    And concerning this community: we are awesome. We are the most bestest and greatestest community in the world. So true.


  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Oh, what I forgot to mention: I prefer Vanilla because it is relatively easy to extend. So if you have special requirements beyond those two plugins and you have the will to learn something, it might be possible for you to write that functionality by yourself (at least if it is only a small tweak)


  • I see, thanks for the info R_J, I'll try to contact the author of the plugin and see if he/she can help me to make it work with the latest version of vanilla and I agree with you, as soon as I saw this forums, I saw alot of potential to do so much with it after looking at the showcase, I'd love to learn how to make plugins myself, I just dont know where I could find guides for it but I'll have a look around to see if I can find some resources for that

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    There is the documentation and the GitHub repo. Both are where you find the most helpful stuff. If you have detailed ideas and share them with us, I will tell you my impression how hard it would be to write such a plugin. I might be even able to assist you in giving hints how to approach or which plugins to look at which did similar things so that you might get an idea on how to get started or solve parts of your problem


Sign In or Register to comment.