Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.

images folder completely missing from zip file

This discussion is related to the VSlider addon.

Hi,

I tried installing this plugin i.e. VSlides version 1.4, on Vanilla 2.8.3 latest version.

But as per installation instructions (http://yoursite.com/forum/vslider/images/image.jpg) , the images folder is completely missing from the zip folder.

I even tried using the older version image folder from version 1.3 in version 1.4.... but it does not work.

Has the developer tested it on Vanilla 2.8.3?


If this doesn't work... any other plugin for 2.8.3 to add image slider to front page?


Thanks

Tagged:

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    I would understand it as if you have to create the folders /vslider and /vslider/images in the root of your forum by yourself.

    If you rename /plugins/VSlider/default.php to /plugins/VSlider/class.vslider.plugin.php and delete /cache/addon.php afterwards, you should be able to use it, I'd guess.


  • Thanks for immediate help.

    I tried all your suggestions including cache/addon.php deleting... although every change automatically creates the same file.

    Unfortunately, it didnt worked. 🤕....

    maybe something is still missing

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    "Did not work" is hard to debug...

    This plugin relies on a JavaScript file which I haven't looked at. It may cause some JavaScript errors. Take a look at the JavaScript console of your browser first to see if you find hints there.

    But adding some slider should be possible with any free available javascript slider script that you can add to your page with the pockets plugin


  • I am not having any experience on javascript. Giving best shot I could.

    This is my site: https://www.theitmall.in/IndiaBizForum/

    When you say "This plugin relies on a JavaScript "... I believe its ...../IndiaBizForum/vslider/js/vslider.js

    basically a file at the root of forum page.

    When I tried to debug using some help on net.... I see that this file itself is never loaded.... here is screenshot:

    This file "vslider.js" is not there in the list:


  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Looks as if you haven't installed the plugin correctly. You need to unzip the plugin to the folder /plugins so that you find that JavaScript file at /plugins/VSlider/js/vslider.js

    Upper and lower case matter, so take care on that. The file /plugins/VSlider/default.php must then be renamed to /plugins/VSlider/class.vslider.plugin.php.

    After that go to https://www.theitmall.in/IndiaBizForum/dashboard/settings/plugins and enable the plugin. At least the JavaScript file should be loaded then.


    Kaspar
  • I removed all VSlider and other changes, and tried once again with clean install... but can't get it working.

    Looks like, Developer needs to give a try with latest Vanilla version, and see, what modifications needed.

    Thanks for all the help.


    Regards,

    Anand

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator
Sign In or Register to comment.