Rich editor can't upload image or attach file while using HTTPS protocol [RESOLVED]

RexChienRexChien New
edited May 6 in Feedback

I changed to HTTPS protocol for my website yesterday.

but why rich editor can't upload the image and attachment when I connect by HTTPS (as bellow)


and It workable if I connect by HTTP


Is there any other configuration I need to set ?

Thanks

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Maybe it is only that you cannot see the button because the icon isn't loaded properly. Look at the html source and see if you can find "richEditor-upload"


  • I only found the richEditor-upload in one place


    I also discover the API v2 will break too if I connect to website by HTTPS



  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Sorry, I didn't meant to search for it in your Vanilla installation folder. Open your web page and then look at the html of that page. Your browser should have a menu entry for displaying the source code.

    Not sure if you might need to have pretty urls for the api, that would be an easy explanation...


  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    You have to have pretty URLs for the API period. Which means you have to have pretty URLs for Vanilla going forward.

    It's been recommended since the 2.3 release and more and more of the site will start using the API internally.

  • Hi @R_J and @charrondev

    Thanks for your recommendation.

    The source code of my web site as bellow

    About the pretty url, I found it works in HTTP protocol by pretty url but it will show Not Found in the browser if I connect by HTTPS with pretty url


    Is there any configuration I can configure to open this function ?

    Thanks

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    If you found that lines in your html source means that everything is loaded but you cannot see the button, maybe because the icon source cannot be loaded?

    I would advice to focus on getting pretty urls working and then looking at the other "problem" again. I believe this will be gone then, too.

    Which web server are you using and what is your server configuration for your forum?


  • Hi @R_J

    My web server is apache2 and it works after I added the Options FollowSymLinks in the ssl.conf

    And everything is fine from now on


    Thanks

    R_Jnexoid
Sign In or Register to comment.