Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Ahhhhh Damn...

edited September 2006 in Vanilla 1.0 Help
I was fooling around with the Administrator settings and created what I thought was a Master Administrator and applying this setting to myself only. In the process I lowered the priveleges of the Administrator role for the other two that hold this role. I accidentally designated myself Administrator and now I'm locked out of the settings, I can't do anything now!!! Is there a way to reverse this??? Any help would be greatly appreciated...

Comments

  • Options
    Can you hack into your MySQL installation?

    Look into the LUM_User table, and find your user name and the values. I use PHPMyAdmin. There, you'll find my role is RoleID = 4, which is the Administrator role (RoleID = 3 is Member, 2 = Banned, and 1 = Unauthenticated) by default. Try changing your RoleID to 4, if it's not that already directly in the DB, and see if that works.

    I'd recommend that you remember what you changed it from, in case that doesn't work, and also don't change anything else in the table :D

    HTH

    Scott
  • Options
    edited September 2006
    I'm in PhpMyAdmin, I see the LUM_Role field. I then see a few fields for LUM_Role: Name Icon Description Active Permission_Sign_In Permission_HTML_Allowed Permission_Receive_Application_Notification Permissions Priority UnAuthenticated What do I edit from here? I don't see what you mentioned above...
  • Options
    I'm assuming here ... I assume you have cpanel as it is the most popular hcp ... Login to your cpanel(yourwebsite:2082) or any other ... find the link that says "MySQL Databases" click on it... Scroll down until you see a link that says "phpmyadmin" click on it ... On the left .. you will see a scroll down menu ... click it and choose the vanilla's database ... You should see now the tables .. scroll until you see "LUM_User" table .... click on the first icon next to the name "browse" ... Now .. find your account ... then click on the pencil icon to edit your account role .... Go to field number two .. which says "RoleID" .. change the number in the white box to 4 then click "Go"(you will find it down) ... try logging in your account ...
  • Options
    I edited my previous response above. I'm going to try what you suggested right now, give me a minute...
  • Options
    It already has a 4 listed. When I log in, I do not see the settings I used to see....? Any other suggestions? Below is what I found on another thread... Go into your LUM_Role table, find the Master Administrator record, and look for the Permissions field. it will look something like this: a:39:{s:23:"PERMISSION_ADD_COMMENTS";i:0;} etc. now VERY CAREFULLY paste that entire field into a text editor, look for the parts that say "PERMISSION_(whatever);i:0" and change them to PERMISSION_(whatever);i:1 instead. copy and paste the new value back into into the database. Is this another approach to the same thing? Or is this entirely different?
  • Options
    edited September 2006
    I fixed it!!! Thanks for your help in this, its been bugging me for two days. Any idea on how to fix the login issue? It keeps prompting everyone for their password...
  • Options
    Are you using Vanilla 1 or something? Because I've noticed that in Vanilla 1.0.1 you can't change your own role.
This discussion has been closed.