Please upgrade here. These earlier versions are no longer being updated and have security issues.

Link from Rate Your Music

Used to work so well back in the days. I could simply fetch a code from a page like this:

And paste it into vanilla.

Now the bb code is not working:

 [url=https://rateyourmusic.com/release/album/ghost/prequelle-1/][img]//e.snmc.io/i/300/w/d784b7f95564a09d953f17a8fcf840c8/6949614[/img][/url]

And the html code is not working:

 <a href="https://rateyourmusic.com/release/album/ghost/prequelle-1/"><img src="//e.snmc.io/i/300/w/d784b7f95564a09d953f17a8fcf840c8/6949614" alt="Ghost - Prequelle"></a>

Any suggestions? We use vanilla on a music discussion message board and we use RYM links all the time.

«1

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    The Rich Editor (Vanillas current default editor) doesn't support BBCode or html like the above. You will see those preview rendered like box as you can see in your own post above.

    If you want to use BBCode or any other formatter, you need to disable the Rich Editor (maybe use the advanced editor instead) and add the following lines to your conf/config.php:

    $Configuration['Garden']['InputFormatter'] = 'BBCode'; // Html, BBCode, Markdown, Text, Rich
    $Configuration['Garden']['MobileInputFormatter'] = 'BBCode';
    



  • Thanks @R_J !

    If I understand you correctly I cannot combine the use of auto embeds (for links, youtube, etc) with RYM-embeds.

    Did I understand it correctly?

  • Actually I can link to the artist/album url like this:

    Which kinda works. However, when I do this on my forum i get:

    Request failed with status code 500

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    RYM should work on your forum, too. But not with pasting html or url formatted links.

    Look at the JavaScript error console of your browser to find possible reasons for this error.


  • asleulvasleulv
    edited May 23

    Once again, thank you @R_J !!

    This is what I'm seeing:


  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    I think there have been similar reports by people who were not using pretty urls. Do you use them? If not, try adding $Configuration['Garden']['RewriteUrls'] = true; to the end of your conf/config.php


  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    You need to find out why yourforum/2018forum/api/v2/media/scrape cannot be accessed: an error 404 would be okay, 500 is not.

    An error 500 most probably gets logged by your web server. If you have access to its log files, you might be one step closer to the solution.


  • Sadly I don't. And they tell me there are no logs.

    I should probably change my host 😒

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    What is the result when you open that url? And what is the url to your normal discussions?


  • The result is this:

    {
        "message": "/api/v2/media/scrape not found.",
        "status": 404,
        "description": null
    }
    

    Url to discussions: http://pmono.no/2018forum/discussions

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    I don't think that's a real account but since there were no spam activities, there's no reason to delete it (yet).

    I've clicked on your link and found it is a closed forum. I don't know how all this interacts, but just to be sure, I would make the forum publicly available, make your test and close the forum again - if that is an option. If you have concerns because your forum posts will accessible for a few seconds, you should think about creating a test forum. But on the other hand, if your hoster is that bad, you should be concerned about your data for other reasons... 😉


  • Ah, sorry about that. Just made it open in case you wanna check it out again.

    Ideally I would like people to be able to see the topics, but not read inside the discussions. Not sure if this is possible.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Do you have a link to one discussion with a non-functional RYM link?

    But in the end I don't think I can be of any help without getting to see the logged error behind that error code 500.


    In order to make your forum only partially available, you would need to do some serious work: "protecting" only the individual discussions pages wouldn't be enough, since discussions are also available through search results, profiles and api calls (and maybe many more endpoints).

    Creating a simple redirect to a custom page with text like "in order to read this topic, you need to become a registered member. Click here to register or sign in" would be quite easy. But as I said before, that wouldn't really hide the content


  • I see the 500 error when writing the post, but after it's posted it shows nothing at all.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Like I already assumed, I'm not able to help 😕


  • Thanks anyway, @R_J .

  • Oh no! I changed to a new host and the dreaded 500 error is is still here.

    At least now I have access to a proper cpanel with logs and stuff.

    I spoke to my new hosts tech support and they tolk me that I need a professional web developer to figure out how to solve the problem.

    He also said the problem is this:

    Does this make any sense to you @R_J ?

Sign In or Register to comment.