Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

One login : get all the Vanillas

edited September 2006 in Vanilla 1.0 Help
Hello This thing is very strange .. I have two Vanillas installed ... one in the folder 'vanilla' and the other in 'translato' ... the problem is that I've 'alnokta' account in both of them but with different passwords but both have administrative permissions ....when I login at any of the two Vanillas ... I'm logged in the other one ... It is really annoying ... because if I try to change a setting in a 'translato''s Vanilla while I'm logged in using 'vanilla''s login page, I get errors saying that php needs write permissions .... so I have to logout then login again through 'translato''s login page ... so the question is .. how to stop that ? and how to teach each Vanilla to mind its own business? In-case you ask about the cookie settings .... it is the default ones .. written by the installers ... Translato: Cookie domain: www.alnokta.ignorelist.com Cookie path: /translato/ vanilla: Cookie domain: www.alnokta.ignorelist.com Cookie path: /vanilla/ In addition to that problem .. I'm suffering also from the same issue mentioned here : http://lussumo.com/community/discussion/3716/remember-me-doesnt-work/#Item_7 Sorry for the long input...

Comments

  • Options
    You need to copy the:
    $Configuration['COOKIE_USER_KEY'] = 'lussumocookieone';
    $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwo';
    lines out of appg/settings.php, and copy them into the conf/settings.php files for each forum, then change the names of them appropriately. e.g.
    $Configuration['COOKIE_USER_KEY'] = 'lussumocookieonevanilla';
    $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwovanilla';
    and
    $Configuration['COOKIE_USER_KEY'] = 'lussumocookieonetranslato';
    $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwotranslato';
  • Options
    Hi Tried that ... but still I get the same problem....
  • Options
    have you tried clearing your cookies while logged out then logging back in?
    if so paste the appropriate parts of each conf file here.
  • Options
    I might be wrong .. I pasted in /conf/settings.php the appropriate parts you suggested ... is that okay?
  • Options
    I assume you put the 2 chunks into different conf files?
  • Options
    Yes .. you can assume that .. I've placed them into these files /vanilla/conf/settings.php /translato/conf/settings.php Should I place them in one file?
  • Options
    So you put:
    $Configuration['COOKIE_USER_KEY'] = 'lussumocookieonevanilla';
    $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwovanilla';
    into vanilla/conf/settings.php
    and:
    $Configuration['COOKIE_USER_KEY'] = 'lussumocookieonetranslato';
    $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwotranslato';
    into translato/conf/settings.php?

    If so, what cookies get set for you when you log in?
  • Options
    "into translato/conf/settings.php?" Exactly ... "If so, what cookies get set for you when you log in?" How can I know that? or should that be visible somewhere?
  • Options
    Which browser are you using? In firefox 1.5, go tools>options>cookies>view cookies.
  • Options
    Is it not the problem that they use the same database, i don't now what your prefixes are ? when u use two different prefixes, _LUSS and _LUSS2 there coudn't be a probleme but i don't know.
  • Options
    @Mini : see the image ... only one cookie because the other vanilla 'vanilla' didn't ask for a password ... just logged in as soon as I login to 'translato' !!! http://img177.imageshack.us/img177/6083/thefreakyvanillivf7.jpg Seriously .. I don't know what is wrong ... my settings in ff is to delete everything(cookies,cache,etc.) by default after I close the all the windows(shut ff down) ... Though in IE .. this problem don't show up ... also I couldn't see any cookies that belong to www.alnokta.ignorelist.com in the 'temp internet files folder' .. may be that is because the first vanilla opened in ff took the cookie and Vanilla sends one cookie ... I don't know ... In K-Meleon : same problem ... but I didn't check its cookies ... @wernerveldman : who said anything about the same database? they use two different databases with two different MySQL accounts ... I said the same user name .... and with different passwords ...
  • Options
    That's only a session not an actual cookie i think. Are you clicking 'remember me' when you log in?
  • Options
    No .. I will try that .. thanks for trying to help
  • Options
    @alnokta: your problem is to distinguish both cookies (if "remember me" is used) and session variable.
    Minisweeper has given the hint for cookies, and I add that for sessionId you should differentiate this setting:$Configuration['SESSION_USER_IDENTIFIER'] = 'LussumoUserID';
  • Options
    edited September 2006
    Nope ... same issue when using 'Remember Me' option @Max_B : I will try that now ... so I just add this line to each 'settings.php' ? I'm just curious .. why didn't Mark add these options as a default? I mean the cookie settings and that extra line .... EDIT : I tried that(just copied them into 'conf/settings.php') and still didn't work ... also I found another issue with Poll 1.3(last comment) http://lussumo.com/community/discussion/2852/2/poll-13/#Comment_44807
  • Options
    @alnokta: just to be sure: this is not just a matter of copying the line, but to differentiate its setting in both Vanilla. This is what you did? And close any Vanilla session or your browser then restart it?
  • Options
    I did all that .. it is the same line($Configuration['SESSION_USER_IDENTIFIER'] = 'LussumoUserID';) to be added to each /conf/settings.php ... right?
  • Options
    No! You must modify this line in ONE of the two install:
    $Configuration['SESSION_USER_IDENTIFIER'] = 'TranslatoID';
    The purpose is to DIFFERENTIATE these ID to avoid the collision of sessions.

    In fact you do not need to copy it in the other install either. That's why Mark let most setting in the main setting file: they are only useful in special case. Then you should copy and modify the relevent setting.
  • Options
    AT LAST IT WORKED! Thank you both for all the help When I added 'TranslatoID' to translato's settings.php ... all things went fine....
This discussion has been closed.