Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.

Any update to use this on vanilla 3.xx?

This discussion is related to the Yet Another Gamification Application addon.

Hi, this plugin looks interesting but 3.xx is not supported, will it be updated?


  • Hi, it's working with vanilla 3.0 but not on windows system because it's not case sensitive operating system.

    Look at @Bleistivt fork here :

    or mine here :

  • thank you!, I'm using

    but when i enable it i can't go to the settings because "Page not found.", any idea how to fix?

  • i just made some changes on the fork and tried it on a fresh vanilla 3.0.2 install and fresh yaga install and it's ok

  • I found a bug in class.reactionmodel.php (double declaration of GetUserCount()

    Now everything's ok

  • In general, for debugging vanilla or plugins issues,


    $Configuration['Garden']['Errors']['LogEnabled'] = true;$Configuration['Garden']['Errors']['LogFile'] = 'vanilla-forum.log';$Configuration['Debug']=true

    in your conf/config.php file

  • put file folder to "plugin" or "application"?



  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    It must be in /applications

  • Hi, this is happening to me right now, did you fix it ? I'll be glad if you could help me :)

  • Put this $Configuration['Garden']['RewriteUrls'] = true; to your config.php

  • Yep, is done, it was one of the first thing we did.

    It's weird, cause I cannot even activate it, When I Activate it, and refresh the page, is deactivated.

    And when i Activate it, and click settings, it says "Page not found"

  • Any fix to this issue?

  • Nobody had this problem ? Nobody knows how to solve it? I'd really be glad if anyone can help me ^^

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    1. You are using picos fork of YAGA and not the original one?
    2. Pretty urls really work on your page?
    3. The addon is activated?

    If all of the above is "I have double checked it and can confirm", then there shouldn't be that problem. What is your forum url (excahnge the domain name by if you like) and what is the address of the page that cannot be opened?

  • .i'm using yaga with 3.2 but i can't test it on every configuration.

    Please be on debug mode and open setting url on a new tab to see why url fails

  • I would like to contribute with my recent experience on that matter (YAGA application and Vanilla 3.2)

    For the last maybe 6 updates I started having a problem. Most Vanilla's administrative GUI interface was unable to show up, with some sort of error. The vanilla forum user interface was working fine all time long. So the problem was related only to the administrative interface.

    Today i finally got enough time to debug the problem.

    I disabled all addOns, disabled YAGA and then the administrative interface gui returned working fine. I learned that the problem was related to YAGA and/or its addons. What I did:

    • I downloaded again Yaga, deleted previous YAGA application folder and reinstalled a fresh copy (same version) of YAGA application
    • I disabled all YAGA AddOns
    • Then Deleted the Vanilla's cache subfolders

    It worked fine and now Vanilla's administrative gui is working fine and YAGA is still working.

    In order to arrive to that conclusiion I had to disable all AddOns and YAGA and then enable one addOn after another and then finaly YAGA and its AddOns. Then I Learned that somehow YAGA was generating for most of Vanilla's Administrative Interface GUI, errors.


  • yguerdatyguerdat Delémont New

    Actually the module is working by me, but I was wondering if it's possible to display the leaderboard on all the pages ? I only have it under the activity pages. I'm interested to have it everywhere.

    Is it any possibility and if yes does someone already does it and can explain me how ?

    Thanks a lot

  • Works well over here, for all of my members and me. Windows, android and linux.

  • @Cirphrank i mean vanilla installed on windows server, not windows client surfing on a vanilla installation.

  • Oh, sorry, now I grab. I actually have no idea about that.

Sign In or Register to comment.