I have broken vanilla

Guys I have broken the install and am getting this error message. It's probably an easy fix for somebody that isn't a total moron,

This is the message

Fatal error: Cannot declare class OAuthException, because the name is already in use in /home5/XXXXXXXXXX/public_html/xxxx/library/vendors/oauth/OAuth.php on line 8

It was version 2.0.18 I tried updating it through the hosting company panel but no go


Anybody help me?

Comments

  • Could I load 3.1 straight over the top, I have the sql details or does the update have to be done through the running site?

  • misifimisifi New
    edited July 16

    I backed it up last week and I have tried restoring the config and oath directories but still no go. The hosting company just updated the php to 7.3 if that is any help.

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff
    edited July 16

    It’s part of the update. It looks like you have multiple plugins enabled declaring the Oauth2 class. At some point along the way we added it into core so make sure you update your Auth plugin too!

    You should also try to search for multiple copies of that file. The one in vendor is likely correct, but it would help if you reported what other files you have of that class.

  • I am a total moron and have no idea how to do that, do I have to do it locally or at the server? I use a hosting company so do not have server side access.

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    Before checking other steps it might be easiest to try the following (especially if it’s a production site and you want to get it back up):

    1. Delete your vendors, cache, dist, and library folders.
    2. Recopy the latest version of Vanilla.

    Its likely you have files from the old version and the new version together and they are conflicting.

    misifi
  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff
    edited July 16

    Also be sure to follow the rest of the upgrade notes here.

    Having files from old Installations can definitely cause issues.

    You’ll also want to get new versions of all of you’re plugins with such a big version increase.

    It almost might be easier to delete all of your plugin and applications folders too and slowly add back new versions

    misifi
  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    Sorry I’m realizing I skipped over a bunch of stuff probably. You could do a new installation and connect it to the old database. Just be sure to visit /utility/update after the setup.

    misifi
  • I tried that, I changed the details in the config.php file to point at the existing database, just got a we have a problem front end. I also tried running /utility/structure but got the "you don't have the authority to do that" message.


    I will try it again with the utility/update switch


    Thanks for all of your input BTW

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    Probably some permission error. I think permissions got changed in Vanilla 2.2? In the mean time you could set the admin flag of your user to 1 using some database viewer.

    If you search around I think there are some Vanilla 2.0/2.1 upgrade threads where people had similar issues.

    misifi
  • That switch worked and I am now in the forum as an admin and can start getting it sorted,. Looks like I owe you a beer :)


    Once again thanks for all your help.

  • Just one more thing, can send out a broadcast email to let the members know that the url has changed?

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    Glad you got it sorted! You may want to rebuild your roles/permission setup because a lot hasn’t changed!

Sign In or Register to comment.