Weird issue with Vanilla 2.2.1 - post's text desappeared

MacitalyMacitaly New
edited September 2 in General Banter

Hi all,

I see that there are not anymore support for 2.x versions but I have to try in any case.

I have a vanilla 2.2.1 version connected with Wordpress since three years, now we updated the server and the new one runs PHP 7.1.31.

It's appened that, migrated the all DB, the structure f forum and topics is intact but, entering inside discussions there are only listed title of comment and users but all post0s text are desappeared, when in comments' table are there as usual.

So, my questions are:

1) somebody know what is the issue and hopefully, how fo fix?

2) there is anybody that I can hire to update Vanilla to the latest version?

Thanks in advance for your time

Mac

Comments

  • Did you test with most basic native template?

    Did you inspect the CSS?

  • First of all thanks to answer :)

    I tried, of course but the problem is that no other default theme are selectable, more, I tried to disable all add ons and nothing changed but could not enable again after.

    I think that there is an incompatibility with the new PHP 7.1.31 but I need it for WP, so for this I ask if there is somebody that can performe the upgrade (in tehory I can do myself but to perform all upgrades that need I'm afraid to do mistakes)

  • Make a test domain, copy/clone current forum install and db.

    Test upgrading on the test domain.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator


    There have been problems with older Vanilla versions and newer PHP versions. But updating to the newest PHP version is the best thing you can do,

    If a downtime for your forum wouldn't be a problem, you can easily do it yourself. Backup everything! The database and also all files. Then nothing can go wrong and you can do the upgrade directly on the live system. There are a few problems that you might come across: maybe every password might become invalid and maybe you need to fix the user roles. Those two things often make problems when updating from an old version.


  • Thanks a lot to everybody for answeres, I will try to manage and let you know.

    Thanks for support ;)

    Mac

  • Ok, I performed all steps described in upgrading instructions, deleting files and folders and running db update and now from front end seems that all is working. GREAT! :)

    BUT, cannot enter in administration, there is a warning: "Could not find the autoloader. Did you forget to run 'composer install' in '/home/comedonc/public_html/forum' ?"

    What I missed?😮

    Could not find a light even in troubleshooting page, so I'm again here to seek for help.

    Thanks in advance

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Make sure you use the downloadable zip from this page to update. Afterwards you should delete all files in the /cache folder. Then there should be no more reason for the error message you see right now.


  • MacitalyMacitaly New
    edited September 9

    Thanks R_I but I already did what you advice, for this I don't understand why it doesn't works.

    Anything else to try on?

  • Check the server user using the folder of your installation

  • The front forum is working fine, users can post and all it's working, only administration and backend isn't working

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Make a radical approach and delete the following folders:

    /applications/conversations

    /applications/dashboard

    /applications/vanilla

    /cache

    /vendor

    Afterwards unzip the file from here into your installation folder again. If prompted if you want to override some files, answer "yes"


  • Thanks R_I the "brute force approach" seems working 😀

    Still persist a weird behaviour and is that from front page, clicking on icon "Account options" and after in "Dashbboard" that link leads to page with the error, instead all other links are working fine and lead to the new administraion panel.

    This happens with every theme I tried.

    It isn't a problem as only me go in administration and I can safetely go into the panel from one of other links, but it's weird, isn't?

    Thanks a lot to everybody for the support, you are a resource 👍️

    Mac

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    The link should be /dashboard/settings and should open the page /dashboard/settings/home. What are those links in your forum?


Sign In or Register to comment.