HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Export from Vanilla1 stops at 20mb

PHP is 5.6 (execution time set to 180s, memory limit 256m and upload file size 64,)

Vanilla2Export is 2.4 (latest official)

Webspace is not full

problem: the export stops and results in a blank page, generating a 20mb file. incomplete.

currently not able to access the error logs. any idea what could cause this problem?

When I use adminer and export all tables, there is not such a problem.


  • PS: there is no info in error.log after script stops

    Is there a way to debug vanilla2export?

  • R_JR_J Ex-Fanboy Munich Admin

    Could it be that there is a problem with one record in the database? From which table is the last dataset in the exported file? Can you exclude the export of that table and see if the export works without that table?

  • despecialdespecial New
    edited October 2019

    I checked different exports and the last lines are always different. sometimes in the middle of a post, sometimes in the "UserDiscussion" table. So obviously not a faulty record imo. I contacted the hoster to ask if there are other limits (like execution time). thanks for the help!

  • R_JR_J Ex-Fanboy Munich Admin

    If it fails on different records each time, I'd agree that it sounds like a timeout.

    If you have a local PHP installation on your computer, you can simply import the Vanilla1 database to your local PC and run the exporter script on your computer. The export script doesn't look for an installation but only for the database (and the uploaded files)

  • Sounds like a plan. I will install it locally and try to export it again like you described.

    Wondering why php.ini says max-execution time 240s but still ends at approx. 30s (default value I guess)

  • R_JR_J Ex-Fanboy Munich Admin

    If you are on a hosted plan you might not be allowed to override all php settings in you php.ini

    Maybe echoing a phpinfo() will give you further insights

  • You are right. I just got the feedback from the support: you can add all the desired stuff in the php.ini and phpinfo shows these values but they are not respected by the server. haha.

    conclusion: it works and the problem was the php timeout

  • R_JR_J Ex-Fanboy Munich Admin

    So you are coming from Vanilla 1? Prepare for a quantum leap 😁

  • yes we are. and yes I believe this will something else :D

Sign In or Register to comment.