Vanillicon font loaded but no icons shown [RESOLVED]

despecialdespecial New
edited October 12 in Vanilla 3.x Help

Testing the yaga application (reactions) and I cannot see the vanillicon icons.

Firefox debugger shows no errors:

vanillicon.css is loaded, so are the fonts within the style rules but when I hover over the source code from the reactions output, the font-family for vanillicon is broken.


any idea what could cause this?

the site is on non-https mode

Comments

  • PS: the spoiler warning icon works, so I have no idead why the reactions wont work

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    edited October 12

    As far as I know, YAGA uses its own reaction icons from: yaga/design//images/action-icons, which you can set via the Reactions option in Settings with Yaga enabled.

    If I remember right, the reaction icons weren't visible by default, so I had to set

    .Item .Reactions > * {
       visibility: visible;
    }
    

    in reactions.css in the YAGA folder

  • @whu606 thanks but this rule only let show the reaction links permanently.

    This is not the problem. The problem is the icons (from vanillicom) are not shown - maybe a language problem?

    Locale is de-DE.php but the language set in Vanilla is "de".

  • Update: I found the problem: the cause of the missing icons is our theme we use

    Boilerplate Theme hides all reaction icons. Fixed it with adding !important to the background sprites in reactions.css

Sign In or Register to comment.