Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

my forum has fallen and it won't get up

edited September 2006 in Vanilla 1.0 Help
Seriously people, how hard can it be to upgrade Vanilla. I downloaded the zip onto my webserver, unpacked it, removed the /conf/ and /extensions/ folders and tried to copy it over the top of my old installation. But the file system wouldn't let me... giving "directory is not empty" as its reason. How annoying. So.. I proceed to copy the my /conf/ and /extensions/ folders over into the unpacked Vanilla.1.0.1 directory, renamed the old /forum/ to /old_forum/ and renamed /Vanilla.1.0.1/ to /forum/. With me so far? I should now have a 1.0.1 install in the same place as my old one with all my old settings and extensions. I try and browse the forum, slap, "403 Forbidden". Ah ok, it's a permissions thing - [reads documentation] - chmod 666 the forum/conf/ folder and it's contents, try to browse forum, slap, "403 Forbidden", try to up the permissions on the conf files - "access denied". Try to "ls -al forum/conf" - "access denied".... WTF... So now I have two broken installations of Vanilla, neither of which I can access the conf folder to recover my settings.... :( Why can't the "check for upgrades" button actually do the bloody upgrade! It's going to take me hours of mucking around with a slow SSH prompt to fix this :( grump grump grump

Comments

  • Options
    TiggrTiggr
    edited September 2006
    Hiho!

    Try: chmod 777 forum/conf

    I belive directories need execution too, for entering them...

    And if yur browser tells you "forbidden" if you access forum/, then check permissions on that directory and it's files too.

    Tiggr
  • Options
    You might also want to remove any .htaccess files you have in your forum root.

    The upgrade button cant do the actual upgrade for security reasons. It has been considered.
  • Options
    hell, I'd settle for a shell script... I've just done a ground up install and it is working smoothly now. Just took me a while to remember the database/username/password :)
  • Options
    when I followed Mark's upgrade documentation it didn't work but when I didn't follow the doc it worked he he I believe he updated since then, a rule of thumb never follow the advice of others lol just kidding ;-) I did just the opposite, instead of adding new files to the current vanilla dir, I started with a fresh set of files then added my conf, extension, theme dir, etc to the new vanilla then upgraded worked like a charm
This discussion has been closed.