Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.

Issues with categories, under 3.2

These are issues with vanilla 3.2, theme Keystone.

I did a bunch of category renames, and additions, without realizing that changing the title doesn't change the URL. Somehow I ended up with two categories that were colliding on the same URL.

Issue #1. On the Edit category page, I am not able to edit the category URL. The input box has almost zero width. I am able to select it. But the cursor doesn't appear in it, and I am not able to enter any characters. See attached screenshot.

https://us.v-cdn.net/5018160/uploads/731/ID9WB2ZIR8XD.png There was an error displaying this embed.


Comments

  • edited November 20

    Issue #2

    This one concerns me more than #1, as I should be able to work around #1, as per the following.

    I figured that I would just clean up by moving my few discussions to a temporary category called Hold, deleting the other categories, and starting afresh. However, it's in a seemingly weird state now.

    This is a new forum, and I actually just have one discussion, which I really need to hold on to. I have it moved into a category called Talks, and the Hold category is now empty. It's behaving fine, in terms of the category filters, and everything that a user would see. Sounds good.

    So I go to delete the category Hold. On the manage categories page, I select the category Hold, and select delete from the menu. The delete category panel comes up, and I click on the button that says "permanently delete all content in this category."

    Unexpected result: a notification comes up that says one discussion will be deleted. But the count for category hold shows up as zero, and my one discussion says category is Talks.

    Then when I experiment and start to delete category Talks, clicking on the same button, no warning comes up.

    So it appears that the delete category system thinks that the discussion is still under Hold, even though I moved the discussion out of it.

    To repeat, filtering to category Talks shows the discussion, and filtering to category Hold shows no discussions.

    I'm afraid to go with deleting Hold until I understand what's going on.

    Any suggestions for troubleshooting here?

    Thanks again,

    Dave

  • edited November 22

    Ok, I got this cleaned up.

    Somehow, through an involved sequence of operations on the front end, involving category creations, deletions and transfers, the category table ended up with incorrect values for the the discussion and comment counters. The warning message about deleting discussions was responding to those values.

    Although the discussion was in category Talks, and category Hold had no discussions, the counters (in field CountDiscussions) were saying the opposite. However, the field CountAllDiscussions was correct. So I infer that the displayed counters were correct, because they are based off of CountAllDiscussions. Whereas the warning dialog is based on CountDiscussions, which was wrong.

    When I ran myforum/dba/counts, it fixed the counters, and that corrected the behavior.

    I tried to reproduce the sequence of operations that caused the inconsistent state, but was not able to.

    Well, thanks for listening. It was helpful to think it through here.

    Regards

    R_J
  • Glad you had that fixed ... I was fixing to respond ... cheers!

Sign In or Register to comment.