HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

My holiday gift

rbrahmsonrbrahmson "You may say I'm a dreamer / But I'm not the only one"NY ✭✭✭

As the holiday season is approching along with the new year I want to wish everyone a happy holidays season and a wonderful year. My gift to the community is the inlinepdf plugin (with a shout to the pdfobject project).

donshakespearemanticore789charrondevphreak

Comments

  • mirXmirX
    edited December 2019

    Thanks @rbrahmson for gift, nice idea! But Settings don't work for me. I'm getting View not found message on my test forum running 3.3.

  • rbrahmsonrbrahmson "You may say I'm a dreamer / But I'm not the only one" NY ✭✭✭

    Don't know why... I just tried it on 3.3 and it worrked for me - I get the settings screen and they are correctly saved in config.php. There should be two settings saved there. Here are mine:

    $Configuration['Plugins']['inlinepdf']['maxviewers'] = 1;
    $Configuration['Plugins']['inlinepdf']['height'] = '700px';
    


  • I just checked once more. The plugin is enabled and Settings button produces View not found. Nevertheless there are next settings in config.php:

    $Configuration['EnabledPlugins']['inlinepdf'] = true;
    $Configuration['Plugins']['inlinepdf']['maxviewers'] = 1;
    $Configuration['Plugins']['inlinepdf']['height'] = '700px';
    

    And PDF url is displayed inline like this:

    😯

  • rbrahmsonrbrahmson "You may say I'm a dreamer / But I'm not the only one" NY ✭✭✭

    The view not found us a vanilla/plugin issue. I'm not sure what's wrong but as I wrote I tested it on the latest vanilla and it worked producing the config.php values I showed above. @R_J - any ideas?

    As for the error message - this seems to be an issue with the pdfobject which unfortunately I can't solve. When the pdfobject script encounters unsupported environment the briwser is supposed to take over. I wonder what environment you are using (os, device & browser).

  • R_JR_J Ex-Fanboy Munich Moderator

    That's an easy one:


       public function settingsController_inlinepdf_create($sender) {
    ...
           $sender->render('settings', '', 'plugins/EventCalendar');
       }
    


    phreak
  • rbrahmsonrbrahmson "You may say I'm a dreamer / But I'm not the only one" NY ✭✭✭

    Thank @R_J ;-))))) Yea, right in my face and I cannot see it... and no wonder it worked for me (we've got a much modified version of that plugin).

    Version 1.1.2 which I uploaded just now should fix this issue.

    phreak
Sign In or Register to comment.