Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Possible issues with Registration and ExtendedApplicationForm 1.0?

Andy KAndy K
edited September 2006 in Vanilla 1.0 Help
Hi all, had a question pop up:

A user can't apply for membership at my site. I am using ExtendedApplicationForm 1.0 and they are getting stuck at "You MUST read terms of service to continue" when they try to hit "Submit", even after clicking the link and reviewing the terms of service. They tried with IE and Firefox 1.5. They tried from two different PCs, work and home. I'm smelling JS or Cookis issue (though this user has his browser set to "Accept All Cookies"). I retested my own site's application process just to make sure nothing slipped, and sure enough it works fine for me and others. Just not this one guy.

So, I was looking for help brainstorming possible issues and their possible resolutions. Anyone know some good places to start digging, troubleshooting-wise?

Thanks in advance for your suggestions!



  • Options
    I've no idea why it's broken, but as a workaround - ask him what username he wants - register him yourself and email him the password. Once he's logged in, he'll be able to change the password to whatever he wants. Also, he'll be able to better report any curious behaviour that may help diagnose the actualy issue at hand
  • Options
    MarkMark Vanilla Staff
    What bigshow said. That link relies on Javascript to register that he clicked the link - so he may have javascript disabled.
  • Options
    Thanks guys. I'm going to go ahead and manual register this one dude for Guinea Pig purposes, and from there I'll just put a bolded statement in the terms of service to help future folks troubleshoot their JS settings. I'll post here if I find anything more once he's in.

This discussion has been closed.