Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Lithuanian language not working

edited September 2006 in Vanilla 1.0 Help
Hi, i've installed Vanilla, but the Lithuanian language is not working. example: 'Ä…' turns to '?', etc... I don't know what to do... what to type in the '$Context->Dictionary['XMLLang'] = ' section? Any ideas?

Comments

  • Options
    I was having similar problems but on the database level .. Check this discussion : http://lussumo.com/community/discussion/3415/2/101-issues/#Item_40 I think you have to install a patched Vanilla to support utf-8 : here is a copy : http://alnokta.ignorelist.com/Vanilla.1.0.1UTF-8compatiblePATCHED.7z I hope that I understood your problem ...
  • Options
    No, it's not that... I have problems with the language file, Vanilla displays translated strings wrong... :( But, thanks anyway... :)
  • Options
    OK, i've found the solution... I edited the language file with UTF-8 editor and it fixed the problem...
  • Options
    Good .. you don't have to take that route as long as you don't use utf-8 encoded text(as once said by Max_B) ...
  • Options
    Fixing the encoding of the translation file to utf-8 is the first step.
    Now you have a working vanilla install... But is it "clean" at the database level?
    Check it out before filling your base. Look at the comment table in phpMyAdmin to see if the text is displaying ok.
    Probably not.
  • Options
    No, everythings OK at the database level...
This discussion has been closed.