HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

installation problem

This discussion is related to the Vanilla addon.

Hello,

I'm installing new vanilla 3.3 on my server.

I have all pre-requisite.

But when i go on my domain I see this error


applications/dashboard/controllers/api/LocalesApiController.php

 99: 
100:         $populate = function (array &$row, array $locales) {
101:             $displayNames = [];
102:             foreach ($locales as $locale) {
103:                 $displayName = \Locale::getDisplayLanguage($row["localeKey"], $locale);
104: 
105:                 // Standardize capitalization
106:                 $displayName = mb_convert_case($displayName, MB_CASE_TITLE);
107: 

Backtrace:

[/var/www/vhosts/domain.com/httpdocs/forum/applications/dashboard/controllers/api/LocalesApiController.php:117] LocalesApiController->{closure}();
[/var/www/vhosts/pron.com/httpdocs/forum/applications/dashboard/controllers/api/LocalesApiController.php:45] LocalesApiController->expandDisplayNames();
[/var/www/vhosts/pron.com/httpdocs/forum/library/Vanilla/Models/LocalePreloadProvider.php:36] LocalesApiController->index();
[/var/www/vhosts/pron.com/httpdocs/forum/library/Vanilla/Web/JsInterpop/ReduxActionPreloadTrait.php:51] Vanilla\Models\LocalePreloadProvider->createActions();
[/var/www/vhosts/pron.com/httpdocs/forum/library/core/class.controller.php:1967] Gdn_Controller->getReduxActionsAsJsVariable();
[/var/www/vhosts/pron.com/httpdocs/forum/library/core/class.controller.php:1471] Gdn_Controller->renderMaster();
[/var/www/vhosts/pron.com/httpdocs/forum/library/core/class.pluggable.php:217] Gdn_Controller->xRender();
[/var/www/vhosts/pron.com/httpdocs/forum/applications/dashboard/controllers/class.setupcontroller.php:155] Gdn_Pluggable->__call();
[/var/www/vhosts/pron.com/httpdocs/forum/library/core/class.dispatcher.php:872] SetupController->index();
[/var/www/vhosts/pron.com/httpdocs/forum/library/core/class.dispatcher.php:289] Gdn_Dispatcher->dispatchController();
[/var/www/vhosts/pron.com/httpdocs/forum/index.php:29] Gdn_Dispatcher->dispatch();


I have PHP version 7.2, mariadb 10.2, ssl.

What is this error?

Comments

  • You need to enable php extention itnl on your server (or get your host to)

    Caygri
  • SamGGSamGG New

    Hi,

    I have just install Vanilla on Debian 10 in a virtual box. There are a few packages to add to Debian.

    Please find below my installation procedure, more or less, because I edited it.

    Best.


    # start installation by an update

    sudo apt-get update

    # install PHP requirements

    sudo apt-get install php

    sudo apt-get install php-curl php-mbstring php-mysqli

    # install a few tools, download zip, unzip

    sudo apt-get install curl unzip

    curl https://us.v-cdn.net/5018160/uploads/addons/3JQXC5NIGUWR.zip --output vanilla33-200509.zip

    # move contents to the web tree (/var/www/html/ is document root)

    unzip vanilla33-200509.zip

    sudo mkdir /var/www/html/forum/

    sudo mv package/* /var/www/html/forum/

    sudo mv package/.htaccess.dist /var/www/html/forum/

    cd /var/www/html/forum/

    # enable access to these directories

    chmod g+w cache conf uploads

    sudo chgrp www-data cache conf uploads

    ls -la

    # add .htaccess file, no change (needed?)

    cp .htaccess.dist .htaccess

    # enable rewrite module to apache2

    sudo a2enmod rewrite

    # add php unlisted PHP modules

    sudo apt-get install php-intl php-gd php-dom

    sudo systemctl restart apache2

    sudo systemctl status apache2

    # install mySQL-like server

    sudo apt-get install mariadb-server

    sudo systemctl status mariadb

    # secure mariadb

    sudo mysql_secure_installation

    # configure mariadb using https://linuxhint.com/install_mysql_mariadb_debian_10/

    # create a database and grant access to a user

    sudo mysql -u root -p

    # back to web configuration in a web browser

    # finalize services at reboot

    sudo systemctl enable mariadb

    sudo systemctl enable apache2 

    R_J
  • thank u for your help @ianw5555 not was active...


    PS forum notification go in spam and when i move in inbox link are not clicable

Sign In or Register to comment.