HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Nothing I change in the default.master.tpl makes any difference. Even if fully deleted.

jforteze1jforteze1 New
edited May 2020 in Vanilla 3.x Help

Trying to make changes to the master.default.tpl, mainly to the footer and nothing has any effect at all. I even deleted every instance of the file and the pages still look exactly the same.

Thought it was some caching thing but it does the same on any browser or computer/phone.

What am I missing? Does the site overwrite any changes to the keystone default.master file? I've searched and read every comment but nothing I do has any effect on the site. I've spent an hour just re-uploading different files and nothing on the site ever changes.


  • Options
    R_JR_J Ex-Fanboy Munich Admin

    Sorry, that post got caught in the spam queue.

    If you have searched for hours, I hope that you have found a hint that you should never change any of Vanillas files. Copy what you need (some theme, e.g. the keystone theme) and customize your copy. Take a look at the documentation to find some hints about that: https://success.vanillaforums.com/kb/articles/152-what-is-an-addon

    If you change files of your theme but nothing happens, try to delete the content of the folder /cache/Smarty/compile. Or if you have made your changes by usign a themehooks file, you might need to delete the file /cache/theme/yourthemename.php

  • Options


    I saw the posts about not changing the source files but I'm just trying to get the site to look right for now, I'll work on cleaning up the method later. That's just my workflow at the moment.

    I'm just downloading the files and editing them manually and re-uploading. I found one other thread from a few years ago where a guy had a similar problem. He changed themes and changed back and it fixed it after deleting the original theme.

    So I must have to delete something for the files to change like you said. I'll try your files first and go from there.

  • Options

    Try clearing the cache in your browser

  • Options

    I tried deleting the cache files and it still displays the same.

    What's weird is even if I rename the all instances of default.master file the site still loads fine and looks exactly the same. I even deleted the one in my theme folder and the site works fine. Cleared the cache, even opened a different browser and loaded the site.

    Something with the keystone theme must not let you change the footer area or even that file. I'm not a coding expert, but I've built tons of wordpress sites and other php based sites so I get the basics at least.

    I don't understand how I can rename the files on the server and the site still loads exactly the same. It must be saving it or rewriting it somewhere else.

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    What's weird is even if I rename the all instances of default.master file the site still loads fine and looks exactly the same.

    Instead of changing more and more in order to see some changes, may I suggest again to simply use the recommended approach?

    I understand that this is not a satisfying answer to your above observations. But if you would have deleted the "correct" files, it goes without saying that there should have been a change visible. But interrogating something like that is pointless, since this "approach" is a dead end anyway. But if you really want to: double check you have delete all files, try deleting e.g. the index.php file, try the anonymous mode of your browser - all things like that. But really: don't waste time on that...

  • Options
    jforteze1jforteze1 New
    edited May 2020

    Well, I copied the new theme to make a custom theme as is the "right way" to do it. Changed the addon.json file and config file as required for the new custom theme. And the same thing happens. Nothing changes no matter what code I change with the footer.

    There must be something new with the latest versions that doesn't work the way the old help questions on this forum says it does. My guess is there is some extra step and all the instructions I look up don't include that step.

    I did notice in all the other help topics similar to this, when the people posted their code samples, their keystone footer section in the default.master file is different than the newest version.

  • Options
    agcyphersagcyphers Nooooop.

    Your host might be using a caching solution. Check your control panel or contact your host.

Sign In or Register to comment.