Stats don't work. Problem with credentials. Please need your help

Hi

I've faced it problem 2 weeks and can't resolve. I have 2 VPS. I installed 2 forums on 2 sites and 2 different VPS. One VPS uses HestiaCP and vanilla forum. Stats work by default. The second VPS withous HestiaCP, I installed everything by myself, I can post it here

apt-key adv --fetch-keys 'https://mariadb.org/mariadb_release_signing_key.asc'

add-apt-repository 'deb [arch=amd64,arm64,ppc64el] http://mirror.its.dal.ca/mariadb/repo/10.5/ubuntu focal main'

add-apt-repository ppa:ondrej/php

add-apt-repository ppa:ondrej/nginx

apt install nginx mariadb-server

apt install php-pear php7.4-cgi php7.4 php7.4-cli php7.4-fpm php7.4-common php7.4-mbstring php7.4-curl php7.4-gd php7.4-mysql php7.4-json php7.4-intl php7.4-opcache php7.4-xml php7.4-soap php7.4-bz2 php7.4-imagick php7.4-zip php7.4-bcmath php7.4-gmp

Rerigister API in statistics doesn't work too. I found a few threads here but can't understand how to fix the problem. No exactly steps there.

Maybe someone from this community can access my 2 VPS and to see where's the problem? Because if I coudn't resolve the problem for 2 weeks of thinking and trying, editing, I just can't believe in myself right now :(

Comments

  • I tried Ubuntu 18.04 too, the same problem...

  • they won't help you cause they don't know too just like you. Support here is disgusting.

    as a solution I can recommend you to install the panel for your main site (www.website.com), then install vanilla. get your Application ID and Application Secret and save it somewhere else. reinstall OS and install vanilla and put there Application ID and Application Secret that you saved earlier. idk if it will work but at least I'm giving the idea, not just rather than just brushing it off as local developers do with vanilla users.

  • KasparKaspar ✭✭

    This is the OPEN-SOURCE product and forum!

    It is a product you get for FREE!

    On this forum it is the community that offer FREE support out of their time and goodwill.

    It is also here you get a bunch of plugins and themes developed by the community for FREE plus a bunch developed by the VanillaForums company, again you get that for FREE aswell!


    You call that "disgusting"?

    Sry but that is disgusting to do!


    You can get the PAID for product including the PAID for hosting and the PAID for support and the PAID for additional plugins here:

    https://vanillaforums.com/en/plans/

    R_J
  • ianw5555ianw5555 New
    edited July 1

    Also the original poster is looking for advice about installing software on his server that is needed to run vanilla, that is outside the remit of this support forum which primarily deals with the installation and problems related to vanilla (on a server that meets the minimum requirements). Of course if anyone has experience in that department, I am sure they would assist.

  • Linux Mint is an open source product, but the developers answer questions, resolve problems and help people what I can't say about Vanilla. Flarum which is new on them forum market is the same open source, but the devs help users, there is a great community even tho it's not even 1.0.0 release (flarum still beta) lol, but Vanilla is 3.3. You see the difference?

  • KasparKaspar ✭✭

    And then you bring versions in to it.

    Devs do answer questions and help on the the open forums, there a plenty of that if you go over the forums.


    I see the difference, sry that you do not grasp it.

    I am not gonna reply to you anymore, that is a lost cause.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @useruseruser sorry about this offtopic comments, but I trust you to be able to filter out what is important for you and build your own opportunity about Vanilla and its community.

    To add some offtopic words here: I don't want to moderate this. Anybody who wants to waste his time on thinking about some angry guy can find out what makes him so frustrated (not why, though)

    Personally spoken Ihave two reasons for not answering 1. I think the answer can easily be found if the person questioning is really looking for an answer and 2. I have absolutely no clue how to solve that problem. I'm not the "Sorry to hear that you are facing a problem, must be awful! Bu I cannot help" posting guy.


    Now here is my short and maybe not very helpful answer to your question: I have no clue concerning your problem. But I would look at the JavaScript console for any errors and maybe the network traffic to see if there are unexpected 404 errors. Beyond that I really don't have a clue...


  • To see the difference you have to registered on something else forum's support. You just have nothing to compare, apparently. The person who is happy with everything is the person who does not want the development of the community. Indeed, there is clearly something to work on. Otherwise, one could think for a long time about why this support forum is less and less popular every year, posts are less and less. And I'm not angry, just telling the truht which people usually don't like and prefer pretending. Please do not answer me, because with you everything is already clear.

  • Thank you for support

Sign In or Register to comment.