HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Broken Theme on Vanilla 3.3 after Upgrade

Hello, I did a manual upgrade from Vanilla 2.3.1 to Vanilla 3.3 a few days ago on a test server.

The upgrade went well overall bar a few minor errors, which I was able to fix thanks to searching this forum and the Forum worked as expected (and what an improvement it was I must say!).

However, today whilst re-visiting the various themes I had installed, I changed the one that I was using (which worked fine) Bootstrap version 2.5.1 by Kasper Kronborg Isager, to one of the newer ones.

Afterwards, I decided to go back to the Bootstrap theme, as I preferred it to the other themes. However, I now get the following error:

"The addon could not be enabled because it generated a fatal error:

Plugin not found.

The plugin you were looking for could not be found.


#0 /home/westnet/mywebsite.co.uk/forums/library/core/class.thememanager.php(618): notFoundException('Plugin')

#1 /home/westnet/mywebsite.co.uk/forums/applications/dashboard/controllers/class.settingscontroller.php(1677): Gdn_ThemeManager->testTheme('Bootstrap', Object(Gdn_Validation))

#2 /home/westnet/mywebsite.co.uk/forums/library/core/class.dispatcher.php(872): SettingsController->testAddon('Theme', 'Bootstrap', 'DC6VlGUkyjjQ1Ar...')

#3 /home/westnet/mywebsite.co.uk/forums/library/core/class.dispatcher.php(289): Gdn_Dispatcher->dispatchController(Object(Gdn_Request), Array)

#4 /home/westnet/mywebsite.co.uk/forums/index.php(29): Gdn_Dispatcher->dispatch()

#5 {main}"

This is so bizarre as the theme worked fine after the initial upgrade?!

I'd be extremely grateful for any help or guidance anyone can provide :)


Sign In or Register to comment.