HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Converting from Vanilla 1 - Porter gives error message

I have an old vanilla 1.1.4 forum I am trying to convert.


But when I run the porter (v2.5), after filling in the values, I get the following error message:

Error in html/vanilla2export.php line 1190: (2) Parameter 3 to Vanilla1::filterPermissions() expected to be a reference, value given

Nothing appears in the apache error log.

I've been testing this on various versions of php just to test, but right now it is running under php 7.2.33 on a CentOS 6.10 install


Any idea what could be going on here?


(I also tried running it under php 5.3, same as the forum currently runs under, and according to the plugin page, 5.3 is supported, but this gives me a blank page and the following error in the error log: PHP Parse error: syntax error, unexpected '[' in /var/www/html/vanilla2export.php on line 577)

Comments

  • Update:

    After spending hours trying multiple php versions on multiple linux distros and versions of the porter script, I finally had some success here. I could not get it to run under 5.3, which is the advertised requirement. Neither could I get it to run under any 7.x version of PHP that I tried, but 5.6.40 seems to have been the solution here. At least it completed without errors and showed me the success screen. I've run out of time for today, so I won't be able to try to import it, but that's beyond the scope of the porter anyway, I trust the export is fine since there where no error messages and file size looks somewhat reasonable.

    Bleistivtjkoerte
Sign In or Register to comment.