HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Please help remove index.php?p= from URL

Hello, I've search for this topic before but I still don't get it what I should do.

I just change domain name, and then the URL is always followed by /index.php?p=/. The problem is, my editor box for make new post or activity doesn't work, like this:

How exactly to remove /index.php?p=/ from URL?

Fast respons would be help. Thank you.


I use 3.3 Vanilla


  • Options

    Enable pretty url's in your /conf/config.php file?

    $Configuration['Garden']['RewriteUrls'] = true;

  • Options

    Thanks for your reply.

    But my forum is broken when I put $Configuration['Garden']['RewriteUrls'] = true; in the /conf/config.php file.

    Do you know why?

  • Options
    edited October 2020

    Make sure you have rewrite rules in your apache .htaccess file

    # Original

    # If you modify this file then change the above line to: # Modified

    <IfModule mod_rewrite.c>

    RewriteEngine On

    # Certain hosts may require the following line.

    # If vanilla is in a subfolder then you need to specify it after the /.

    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)

    # RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]


  • Options

    It worked!

    Big thanks. 😊

Sign In or Register to comment.