HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Database migration from 2.1 to 3.3

Hi,

I am trying to export/import content of database of version 2.1 to 3.3 and looking for someone who does offer custom work. Unfortunately, I couldn't do it myself and all i get is "Something has gone wrong..." message.

P.S. Yes, I've enabled debug mode but there is no further details except this useless error.

Comments

  • I think you would need to import the database into a 2.1 forum and then upgrade to 3.3

  • R_JR_J Ex-Fanboy Munich Moderator

    There is no export/import way during update. If you start from a clean installation of Vanilla 3.3 you normally only have to do 3 steps:

    1. Backup your old database. That should always be the first step ;-)
    2. Edit conf/config.php and change the database settings from that new installation to your old database
    3. Run /utility/structure

    And if you start with a new installation of 3.3, you do not have user uploads in there. So you should copy the /uploads folder from your old installation to the new installation.


    Not much to do. But if you still need support, drop me a line


  • Thanks guys for the answers. @roadrunner already helped me a lot and i was able to sort few things. However, I still have a problem with users being invisible in the Dashboard > Moderation section. The list of users is empty.

    @R_J Already did it but when I run /utlility/structure, this is what i get https://prnt.sc/vaci8x

  • R_JR_J Ex-Fanboy Munich Moderator

    The above three will always remain and they are harmless. The last one is caused by the stub content plugin (which you will not need) so if you deactivate this plugin that last line should also disappear. But even if it is there, that is no problem.


    So is your forum up and running?


  • R_JR_J Ex-Fanboy Munich Moderator

    Oh, just saw that this answer is also "hidden" in the comment section ;-)


    Please take a look at your database: how does the table GDN_User look like? Is it spelled like that? Does it contain all the users? Are you sure that you already changed the database credentials?


  • @R_J Already disabled Stub Content plugin and the last one disappeared ;) According to user's list, yes, they exists of course and database seems to be ok. You can see on the following screenshot https://prnt.sc/vakvvp that the list is empty. It shows the number of users in database but nothing else.

Sign In or Register to comment.