HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Data too long for column 'AllIPAddresses' at row 1 update GDN_User `User` set DateLastActive = :Date

Hello everybody,

First of all, my name is dummy so please keep it as simple as possible!

Through 'Installatron' on my webservers page I installed Vanilla forum 2.1.13 (can't install any higher) and all went well.

Now I can not log in anymore, it says

Data too long for column 'AllIPAddresses' at row 1 update GDN_User `User` set DateLastActive = :Date (etcetera)

Then ANY page says 'Something has gone wrong'

I didn't do anything and it seems unlikely the forum has a mind of it's own. How on earth is this possible?

If I remove all cookies the first forum page appears again so I try to log in and then the same message appears and after that all pages are say 'Something has gone wrong' again.

Nice!

Comments

  • KasparKaspar ✭✭

    Why can't you go any higher than 2.1.13 that is from 2015.


    The newest is 3.3 and is added to Installatron

  • El_SofaEl_Sofa New
    edited January 1

    Hello Kasper,

    Shared webhosting and when trying to install a higher version Vanilla says that the requirements are not met. Any version that starts with 3 cannot be installed so I just picked the top one that could.

    Anyway, any idea why things change themselves and what I can do to stop that?

  • BleistivtBleistivt MVP
    edited January 2

    Anyway, any idea why things change themselves and what I can do to stop that?

    Things are not changing themselves, your environment is changing. This is most likely an issue with ipv6 support. Compare ipv6 usage when Vanilla 2.1.13 was released in 2015 (!) to now:

    https://www.google.com/intl/en/ipv6/statistics.html

    The fix is to update to a more modern version of Vanilla.

  • El_SofaEl_Sofa New
    edited January 2

    Thank you.

    Some background information. I used to have my own server, Covid arrived, business went down the drain. Decided to get rid of 10 websites. I kept 3, one with a forum. They transferred the 3 to the cheapest hosting and I lost 800 members. The forum was moved but many functions no longer worked properly. 'Sorry, applications don't come with a warrantee'.

    So I reinstalled the forum, that worked ok for a week. And then this happened. Embarrassing the least. So basically you are saying that the older versions that can be installed should not get installed because they're 'rubbish' not because they're bad of course but because the environment has changed?

    I am getting the feeling that not only Covid has hit me.

    Does this mean I can't get rid of the highly frustrating  'Something has gone wrong' pages?

  • KasparKaspar ✭✭

    "Vanilla says that the requirements are not met"

    Check requirements


  • Vanilla says the requirement ARE met, just not for the 3 series. And if the requirements are met for 2.1.13 the forum should work instead of showing  'Something has gone wrong'.

    I read the link you posted here - thank you - and I will contact the hosting company.

    But i still find it weird that it is possible to install certain versions without a problem but they don't seem to work. Mind you, it worked fine for a week.

  • I should email the forum users but as I cannot access the forum .......... in which folder can I find the email addresses of the forum members?

  • K17K17 Use Linux :D Paris, France ✭✭✭

    User emails are not in a folder but in your MySQL database (basically in GDN_User table).

  • Thank you

    K17
  • K17K17 Use Linux :D Paris, France ✭✭✭
    edited January 3

    You're welcome 😁

    And don't forget, if you can't use updated software, change your hosting provider. As it has been said, your trouble with IP adresses fields are due to IPv6 being not supported yet on 2.1. So yes, the environnement have changed on internet, and IPv6 has started being the norm.

    It's not Vanilla fault if it's not working today for a version that is not only considered old, but obsolete. And of course, a lot of security upgrades have been done in 5 years.

    And if you wonder why your install worked for a week, it is simple: no IPv6 was used by a user during this week. Then one did and patatra! it broke. That's to adress this kind of trouble that we troubleshoot forums for new updates. So again, the environnement has changed, and the error you had was not weird. And the requirements of 2.1 are not possible anymore since 2.1 need IPv4 only.

    Hope I was clear enough, english isn't my mother language and sometimes it's not easy 😅

  • El_SofaEl_Sofa New
    edited January 3

    Bonsoir,

    I have already sent an email to the provider asking to clear this up. I am not a native either and a common language (luckily English if I may say as a Dutchman) used between non-natives has only one function and that's to communicate.

    I am just pissed off as I lost 850 members when they moved the website to another server but obviously that has nothing to do with Vanilla.

    Anyway, for those who are still here, life goes on!

    K17
  • Back again ........

    I have installed the latest version of Vanilla and it works.

    I have changed some definitions and uploaded a locale.php

    All ok but, I copied the definitions from an old file on Github and some of the text that I'd like to change cannot be found in this file as obviously it's old and texts have changed.

    For example,

    I get this when I register a second account and I would like to change this text.

    -------------

    Confirm Your Email Address

    Hello Playa! You need to confirm your email address before you can continue.

    -------------

    WHERE can I find the php in the lastest Vanilla version with all the definitions? (So I can copy these and change the text?)

    Thank you!

Sign In or Register to comment.