HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

A new role does not come with Permissions

Hi, I migrated my board from MyBB. Currently, I have numerous confusing terminology on my Roles page. I managed to add necessary permissions for Admin and associated with the Role administrator. The same with a moderator Role.

In order to avoid confusion, I tried to create 2 new `Roles`, 1 admin and 1 moderator. While I am able to create those roles, the permission set is blank/zero. It would appear that the Role created does not inherit the default set of permissions for Admin or Moderator.

I would like to understand how I can create a moderator ( and admin if it is not complex ) Role afresh with the default set of permissions for that Role. So that I can add the mods to that particular Role. Thanks.

Comments

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    There is some baked in functionality which cannot be changed through the Role Settings. That's why those main roles exist, I'd say.

    But to clone a role you would need to use some database tools (most people have access vie PHPMyAdmin). You need to work with table GDN_Permission. First you need to identify the RoleID of the origin role, then duplicate all the lines with that RoleID in the table and in the last step change the RoleID in the duplicated rows to the RoleID of the new role (that you should have created before)

  • Options

    I have not tried GDN_Permission before so kindly allow me to continue my question. Is it normal in Vanilla that when we create a Role - a moderator user group, it comes with blank/zero permissions ? All I want to do is create a basic Vanilla moderator group and switch current mods to it through the `Dashboard` since I can change the user group as admin.

    It is almost fine now. But I want to see what a default Vanilla moderator group permission looks like. Thanks.

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    Oh, sorry, I misunderstood. I'll post a picture as soon as I can

  • Options
    KasparKaspar Moderator
    edited March 2021

    Edit: Ah nevermind it does not do what I thought.

    *******

    As I understand it, issue is no permissions in the default admin and mod roles - so a reset of default roles is needed

    https://open.vanillaforums.com/discussion/comment/219688/#Comment_219688

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    That question hasn't been asked for a long time. Sometimes people needed the default permissions of roles. That link above should provide useful information, but it might be too old. I can only provide some screenshots from Vanilla 4


    But here is an export of my GDN_Permission table. It will solve your problem faster if you know how to deal with a database


  • Options
    R_JR_J Ex-Fanboy Munich Admin

    And an explicit but short answer to your question: yes it's normal that a new role has no permissions.

  • Options

    Thanks. I will try to add this now. :)

Sign In or Register to comment.