HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Was working OK. Now cannot login

I've had a hunt around the forum but haven't found a similar issue.

I am running Vanilla 3.3 on a shared server that was installed using Installatron (perfect for me as it's a one click install). It's been working fine for about a year now. It is installed in a sub folder of the main website. It is set to auto-update on minor updates but as far as I can tell there haven't been any. Server is running PHP version: 7.3.6

Today I cannot login using the credentials stored on my system. It accepts the user/password details but doesn't log me in. The three little squares blip a few times then the page reloads with username/password empty. It does not present any error message either.

I 've tried clicking the forgot password link and I get a reset email OK. I click on the Change Password button and it takes me to the reset page. I enter a new password and click save. Enter login details and new password and it doesn't log me in.

I have also put a similar query on my ISP as I do not have a clear idea which side of the fence the problem lies.

Any thoughts would be appreciated.

Tagged:

Comments

  • manticore789manticore789 Australia New

    If you are on a shared web host you should be able to revert back to a previous backup maybe going back a week or so, to see if you can login. That way, you will know the issue is due to vanilla and not your web host. That's a start at least.

  • Ahh. Although I thought it was backing up, apparently not!

    Host has updated the admin password but I still cannot login.

    I'll see if I can uninstall and re-install using the existing database.

  • Alternatively, if I backup the database and do a clean install can I import the existing data to the new database?

  • My daughter can login OK. And also goes through the password reset OK.

    MY wife uses Sea Monkey and the password reset failed as the page wouldn't load in Sea Monkey.

    If I use Edge rather than Chrome the password reset works OK and I can login.

    I've been using Chrome for years. Must have been an update/config change in Chrome that's messed things up.

  • R_JR_J Ex-Fanboy Munich Moderator

    Take a look at the JavaScript console of your browser. Sounds as if there are some js issues


  • Sorted. Wierdly, incognito mode worked OK.

    So:

    Uninstalled Chrome and re-installed it.

    🙄

  • Thanks for your suggestions. Helped point me in the right direction to isolate the issue.

Sign In or Register to comment.