HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Fatal Error HTMLDocument.php

Hello, I just installed the forum on my vps but unfortunately it gives me an error. Can you help me please?


Comments

  • CaylusCaylus ✭✭

    Hey Dyplo, seems like the core php DOM package is not installed on your VPS. Apparently some Linux distributions seperate it from the rest of core php in a seperate package, for some reason.

    Do you have access to command line? This command should solve the issue.

    sudo apt-get install php-dom
    

    Or

    yum install php-xml
    

    depending on your exact Linux version.

    BleistivtR_J
  • I already made this command on the console. But the problem still persists.


    I am running Debian 10 so this is the command (sudo apt-get install php-dom)

  • Do I need to reinstall the forum on my vps?

  • CaylusCaylus ✭✭

    Have you restarted your VPS?

    Could you check afterwards

    php -m
    

    To see if the dom and other relatives modules as xml, xmlreader, SimpleXML appear in that list?

    I don't think you need to reinstall the forum, only restart your server.

  • I restarted my vps. But now it gives me another error.


  • CaylusCaylus ✭✭

    Good to hear we've at least solved one issue! XD

    The new error is due to a file permission issue. PHP doesn't have the right permissions yet to create necessary directories and such.

    This stackoverflow answer describes how to figure out which user you have to give permission to write files in your directory.

    https://stackoverflow.com/a/49566838

    R_J
  • Perfect! Thank you, it worked.


    But unfortunately I have another problem I don’t see what to do :/

    I'm sorry :|


  • KasparKaspar Moderator
    edited May 12

    Do you have those extensions enabled?


    How may very depending on your host control panel

    Example

    https://manage.accuwebhosting.com/knowledgebase/2331/How-to-EnableorDisable-PHP-Extensions-From-cPanel.html

  • Logically yes. I did the installation of php, mysql and I even secured mysql.

    But on the other hand I can’t access phpmyadmin

  • It's good ! Thanks you

    Now I need to find a way to access my database

Sign In or Register to comment.