Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

open_basedir ???

edited July 2005 in Vanilla 1.0 Help
(Before I begin I've just got to say I don't actually have any idea what I'm talking about)

I still have a bunch of errors on my site, the top most of which references open_basedir.

What the hell is this? Doing some googling I'm led to believe its a common error involved with file uploads.

I've tried 2 things to fix it, one being mark's suggestion with using relative paths:
Open up appg/settings.php and edit line 21 from this:

define("agAPPLICATION_PATH", "/path/to/vanilla/");

to this:

define("agAPPLICATION_PATH", "./");

and see if that works.
and the other thing I've tried is changing all the copy() functions in the code to move_uploaded_file() as that seems to be the proper way of handling uploaded files and is supposed to take open_basedir settings into account.

Neither of these things have had any noticeable affect, and the error messages are the same still.



  • Options
    MarkMark Vanilla Staff
    I ran a google search, and the first result looks like a winner:

    For certain PHP installations, the "open_basedir restriction in effect" error message may be displayed when you try to upload images or files. Your hosting provider or system admin may have restrictions on which directories can use "includes." Run phpinfo.php and do a find on "open_basedir." If the setting is something other than "no value" then you might have to install dotWidget in the directory shown. Check with your hosting provider.

    If you don't know how to "run phpinfo.php", just create a blank text file. Open it up and put this inside it:

    <? phpinfo(); ?>

    Then save it and rename it to phpinfo.php. Upload it to your server and take a look at what it says when you load it in a web browser.
  • Options
    whoa, deja vu
  • Options
    Oh yeh sorry, forgot to add that, it was in my other post. phpinfo

    Ultimately I'd rather have a workaround I could implement without going to my isp - I don't have access to my configuration files.

    However, if that is the only way, what is it exactly that I should be begging my isp to change for me?
  • Options
    Oh and as for deja vu, that post was originally for installation woes. Its installed now, so no more installation woes... it just doesn't work properly
  • Options
    deja vu retracted
  • Options
    MarkMark Vanilla Staff
    Okay, I've got an idea.

    Open up the offending file (appg/init_internal.php) and replace this:


    with this:


    and give it another go...
  • Options
    looks like we're getting somewhere. Now the error messages only appear on the sign in page, and all similar pages. the actual forum has no errors now, but signing is a bit hit and miss, sometimes requiring multiple attempts
  • Options
    MarkMark Vanilla Staff
    edited July 2005
    Okay, open up the appg/init_external.php file and find the same "headers.php" line and replace it with the same thing. That should solve your problems. *whew!*
  • Options
    Got it - I made the same modification to the init_external.php as well. Is this something you might make default, or will I have to edit this with each new build released?
  • Options
    MarkMark Vanilla Staff
    Thanks for being persistent with this, btw. It will be fixed in the next revision (so no-one else will have to go through what you did).
  • Options
    Argh you beat me thank you very much
This discussion has been closed.