HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Setting for {Target}?

This discussion is related to the Vanilla jsConnect addon.

I have Vanilla Forums enabled, using the enbedded version. This means that I am using the Vanilla Single Sign-on Integration plugin. The site is being redirected from linker-wenzel/forum to linker-wenzel.de/community.

Plugin and WordPress are both latest versions.

I copied all data from the “Security Settings for Single Sign-on” into jsConnect settings according to the guides I found (including the 2013 youtube video). The jsConnect Test is showing: “The SSO test was successful” and I can see all that stuff like: “The user is signed in”, “Known User Fields”, “Token Details”.

However here are the error messages:

1.) One or more of your connections has warnings. Edit a connection with warnings to get more information.

2.) Your sign in URL does not specify a {target}. You have to specify a redirect variable or else your SSO may not work.

My assumption is, that the signin URL is just wrong:

https://www.linker-wenzel.de/wp-login.php?redirect_to={Target}

I have Vanilla Forums enabled, using the enbedded version. This means that I am using the Vanilla Single Sign-on Integration plugin. The site is being redirected from linker-wenzel/forum to linker-wenzel.de/community.

Plugin and WordPress are both latest versions.

I copied all data from the “Security Settings for Single Sign-on” into jsConnect settings according to the guides I found (including the 2013 youtube video). The jsConnect Test is showing: “The SSO test was successful” and I can see all that stuff like: “The user is signed in”, “Known User Fields”, “Token Details”.

However here are the error messages:

1.) One or more of your connections has warnings. Edit a connection with warnings to get more information.

2.) Your sign in URL does not specify a {target}. You have to specify a redirect variable or else your SSO may not work.

My assumption is, that the signin URL is just wrong:

https://www.linker-wenzel.de/wp-login.php?redirect_to={Target}

What is the correct setting for {Target}? I know that this need to be tweaked but this goes beyond my skills…..}? I know that this need to be tweaked but this goes beyond my skills…..

Sign In or Register to comment.