Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

error in termsofservice.php

Hi

i just mentioned that there's something wrong in the termsofservice.php (also in version 1.0.1 i think), i got this error:
Fatal error: Call to undefined function GetUrl() in /home/.../languages/Deutsch/definitions.php on line 569
is it an mistake of mine or the German Language?

Got it to work by adding this line to the termsofservice.php:
include("appg/init_vanilla.php");

Comments

  • Options
    hi, also using language "Deutsch", same error-message. i first included the "function GetUrl ($param1,$param2) {}" in the code of termsofservice.php, and indeed firefox and internet-explorer showed them (firefox even with the right german "umlaute" (&auml and so on), internet explorer made mistakes with the "umlaute". iguess that's because of the "en-ca" instead of "de-de", but as i am no coder, only copy&paste, i don't know how to repair that. i most often use opera, but opera still shows the old error-message, and it's no cache-problem. Including "include("appg/init_vanilla.php");" only had a blank popup-page as consequence, so i removed it. ideas anyone how to solve this issue? thanks a lot in advance.
  • Options
    edited April 2007
    Same problem here.

    scythoior: where did you include the
    "function GetUrl ($param1,$param2) {}"
    in thersofservice.php) Did this solve the problem?

    I would actually like to disable the whole terms of services business. Any idea how I can do that?

    Thanks.
  • Options
    in the termsofservice.php (in the vanilla root-directory) i pasted

    function GetUrl ($param1,$param2) {}

    right after the description (so the file starts with
    <?php
    then comes the description (/* blabla descriptiontext */) and then
    function GetUrl ($param1,$param2) {}
    (below is "include "./appg/settings.php"); and stuff).

    Strangely it works in Opera too now, so Firefox and Opera display it with the correct "umlaute", only internet-explorer displays it with incorrect "umlauten".

    I'm still no coder, so everything i do is simple trial and error.
  • Options
    Thanks scythoior! Now it works.

    :-)
This discussion has been closed.