Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

HELP: can't change my own permissions

edited December 2008 in Vanilla 1.0 Help
I updated to vanilla 1.0.1 this morning and had to get attachments 2 to make it work (there were apparently some problems with the older attachments version - there are some posts about that here). But now I have a really odd problem: I can change permissions to add attachments for all user roles... except for my own user role (the high admin role). How do i fix this?? I am in the dark here! I'm trying to change the following permissions (to set them to work): # Add attachments # Manage attachments they are currently untagged... other permissions seem to be unable to change too. I get the following error message: "Forbidden You don't have permission to access to this document on this server." I find this EXTREMELY odd...


  • ok, after reassigning some other user roles i got someone to check it out for me he could only change 1 permission each time and then had to resave - trying to change more than one resulted in the same error and in the end, the "check for updates" just doesnt work - it always gives the same error maybe it is a problem with this update stuff?
  • MarkMark Vanilla Staff
    What are the errors you get?
  • It simply displays a standard Forbidden page (as if I were visiting the wrong directory) "<b>Forbidden</b> You don't have permission to access to this document on this server." The problem now seems to be purely with the option 'check for updates' - as te admin I now cannot check for updates anymore!
  • With a new Install I just did for another forum I am experiencing the exact same issue. Any fix yet?
  • I also can't change certain role/permission settings for the Admin. It works fine for the regular Members but not for myself.

    For example: when I want to change the Admin name from "Administrator" to 'Admin" it gives that same error.
    Or when I want to give the Admin the right to post/edit a poll, same stuff.

    Is there a file somewhere that arranges these things that might be set to the wrong CHMOD settings??
  • Dang,

    I've setup a new Vanilla Forum for a different purpose... and I'm running into the same issues. For some reason I can alter permissions for standard members/users, but I cannot alter anything that has to do with the Admin role. E.g. after installing the delete comment extension, I can't give myself the rights to delete comments!

    Any tips?
  • After searching the forum for a while, I found that this solution (while otherwise described) solves the problem: Access denied 500 error on settings.php
This discussion has been closed.