Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Vanilla on SSL connection small problem.

edited October 2006 in Vanilla 1.0 Help
Im running vanilla on a SSL connection since my isp blocks port80. https://b0x.strangled.net note its HTTPS the problem im having is when you logout then goto the main page and try to log back in... you get a url that looks like this https://b0x.strangled.net/vanilla/people.php?ReturnUrl=http://b0x.strangled.net/ notice the Return URL doesnt have httpS just http. i was wonder how i would go about fixing this... this i the only drawback to running on a SSL connection i have found. note, this server has instant membership incase you want to test it for yourself. any help would be appricated. -monst

Comments

  • Options
    I don't exactly have a solution but I'm weirded out by the fact that an ISP would block port 80. It's like a milkbar that disallows dairy products.
  • Options
    cox.net started doing when the codered virus was going out. really sucks they dont reenable it.
  • Options
    Look into appg/settings.php and you'll find something like 'SAFE_RETURN_URL' or similar which contains that returnurl path up there. Copy that whole line from appg/settings.php into conf/settings.php and change it to a https:// and you should be alright.
  • Options
    edited October 2006
    $Configuration['BASE_URL'] was the closest thing i could find, and that is defined properly in conf/settings.php
  • Options
    I have Vanilla under SSL working OK. This comment helped me get it working initially. http://lussumo.com/community/discussion/1661/#Item_9 If you look a little further down that thread, I added a couple comments where I explain a couple other configuration things I had to change to get some extensions to work under SSL.
  • Options
    thanks that worked perfectly.
This discussion has been closed.