Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

CAPTCHA errors

edited October 2006 in Vanilla 1.0 Help
I installed CAPTCHA 0.2.0 and I get this error message: Notice: Undefined index: CAPTCHA_ON in /home/digital/public_html/extensions/CAPTCHA/default.php on line 27 any ideas? Also, I need a COPPA agreement of some sort, anyone know of an addon/extension or anyway to add a COPPA disclaimer to the registration process?


  • Check vanilla/conf/settings.php for $Configuration['CAPTCHA_ON'] if not, delete all the other $Configuration['CAPTCHA_* and reload vanilla.

    Check again vanilla/conf/settings.php. If there is still no Configuration['CAPTCHA_ON'] check the permissions of on vanilla/conf/settings.php.
  • Alright, it took a lot of work on my own part, I had to do some SQL work as well. I have it installed, however, it wont load the CAPTCHA image, all it says is "Visual CAPTCHA". What can I do about this?
  • Sorry, I forgot you had to delete a field in the database.

    Do you have the GD 2.0.1 and the FreeType libraries intalled?
  • Not sure, I will have to check that out.
  • Create a file with <?php phpinfo(INFO_MODULES);?>
    Once you have checked if GD and FreeType are installed delete the file
  • Its showing me GD 2.0.28 with FreeType Support enabled.
  • Notice: Use of undefined constant CAPTCHA_PATH - assumed 'CAPTCHA_PATH' in /home/digital/public_html/extensions/CAPTCHA/image.php on line 6 Notice: Use of undefined constant CAPTCHA_PATH - assumed 'CAPTCHA_PATH' in /home/digital/public_html/extensions/CAPTCHA/image.php on line 6 Fatal error: Cannot instantiate non-existent class: phpcaptcha in /home/digital/public_html/extensions/CAPTCHA/image.php on line 7
  • I fixed the first two errors, however, the third is still there.
  • It's late here, I will look at it tomorow. the problem might be he can't find vanilla/conf/extensions.php from init_vanilla.php
  • Concerning a COPPA agreement, maybe the easiest thing would be to add this to the TermsOfServiceBody dictionary item in the definitions.php file. I would think that this should be there by default. However, if you want to add a separate confirmation that you have read the COPPA agreement, then that would be a different matter. Mark, what do you think?
  • I've just uploaded the version 0.2.1

    @ rkrizan: Let me know if it doesn't fix your problems.
  • edited October 2006
    I've uploaded the latest version and I'm still getting the following error..

    Undefined index: CAPTCHA_ON in /home/chrisleg/public_html/forum/extensions/CAPTCHA/default.php on line 27

    Update: After removing all of the $Configuration['CAPTCHA_* portions, like suggested, I get the following error and I am unable to access the forums at all...

    Error Message
    Could not Add the CaptchaDisableDescription field to the User table
    Affected Elements
    CAPTCHA Installer.OpenConnection();

    The error occurred on or near: Duplicate column name 'CaptchaDisableDescription'
  • edited October 2006
    which $Configuration['CAPTCHA_* were in vanilla/conf/settings.php?
    You have to delete the CaptchaDisableDescription column in the user table
  • I can't reproduce this error (tested om php 4.3.10 and php 5.1.4), so I just guess.

    You can try the last version 0.2.1a (You still have to delete CaptchaDisableDescription from the user table first)
  • Well so far its working just fine, although it appears it cannot create the new data row in the user table. UserManager.CreateUser(); The error occurred on or near: Unknown column 'CaptchaDisableDescription' in 'field list'
  • Alright, I added the table myself. No big deal. Works great now, thanks.
  • It is working for me.

    Check that CaptchaDisableDescription is in the database (If you installed the extension manually or if the colomn hasn't been installed, the query is ALTER TABLE `LUM_User` ADD `CaptchaDisableDescription` TEXT;)
    If it is there, check that CAPTCHA/conf/database.php look like that:<?php // Database tables and columns $Context->DatabaseColumns['User']['CaptchaDisableDescription'] = 'CaptchaDisableDescription'; ?>
    You can try to had $DatabaseColumns['User']['CaptchaDisableDescription'] = 'CaptchaDisableDescription';
    into vanilla/conf/database.php.
  • Everything seems to be working fine now.

    Thanks for all the help...
This discussion has been closed.