Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Latest Discussions 1.0 error

edited November 2006 in Vanilla 1.0 Help
Hi folks,

I've just tried this new extension, which works fine, except a little problem. A big one, in fact.
It works perfectly when I'm authenticated, but it goes crazy when I'm not. Here's what I get when I click on any tab as a guest:

Warning: mysql_query() [function.mysql-query]: Access denied for user 'ODBC'@'localhost' (using password: NO) in ..\extensions\LatestDiscussions\default.php on line 25

Warning: mysql_query() [function.mysql-query]: A link to the server could not be established in ..\extensions\LatestDiscussions\default.php on line 25
Access denied for user 'ODBC'@'localhost' (using password: NO)


Would somebody have a clue?

Comments

  • Options
    edited October 2006
    For some reason it doesn't seem to have connected to your database yet, which is strange, as in the order of execution it says that it loads all the database information (password, user etc) and connects, before loading the extensions. Which DB system are you using? as I may be able to send you a hack which would correct this.
  • Options
    On local I'm running on MySQL 4.1.14, but I didn't try it on my live site yet, which runs on MySQL 5.0. In fact, I wonder if it has something to do with the fact my local DB don't use any password. I'll try it on my live site and let you know what happens.

    Thanks for this extension by the way, it exactly appeared when I needed it :)
  • Options
    Ok well, it works on my live forum, so it doesn't matter :)
  • Options
    Ok thats cool, glad you like it.
  • Options
    I thought I would try again to get this extension to work, but I still get the same errors as above on my host. My host is running php 4.4.3 and mysql 4.1.21-standard. Is there anything I can do to get this to work?
  • Options
    Does your database use a password?
  • Options
    I feel stupid. I didn't have the latest version of that extension. Once I used that one, all is working. Sorry.
    But it would be nice if we did have a way of identifying the latest updates to the extensions we use.
This discussion has been closed.