Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

New Vanilla-Installation: "The page cannot be displayed"

edited November 2006 in Vanilla 1.0 Help
I installed Vanilla to my local Apache without any problems. But if i wanted to install it on my web server (phpinfo: www.e-faux.com/?info=tungsten) i can install it in a normal way, but it won't show any Vanilla.
In Firefox, i see NOTHING. No <html> no nothing (www.e-faux.com/vanilla); in the Internet Explorer i can see an error: "The page cannot be displayed".
I tried to find this error, but i didn't. But: If i set an "die('x');" BEFORE line 42 in appg/init_vanilla.php (before $Context = new Context($Configuration);), i can see the "x" in the browser; but if i set this die('x') AFTER this line, i cannot see anything, like before. So i taught, the error is in this line, so i browsed to library/Framework/Framework.Class.Context.php and searched for the creator of the Context class. And here one very strange thing: If i put the die('x') at the last line of the creator (before line 82), i can see the "x" in the browser. Huh? Why this? If i put it here, i can see it, but if i put it after the location the routine is called,i CANNOT see it?!
What is the problem?! I tried to upload all files once again, but no other effect, also changing from binary to ascii FTP mode didn't changed anything. I can see the installation script of Vanilla without any problems.

Regards Faux

Comments

  • Options
    NickENickE New
    edited October 2006
    might be a fatal mysql error, or perhaps a php one if you've disabled error notices in the page

    try to see if php records any errors when that page is accessed, and make sure you mysql info is correct
  • Options
    edited October 2006
    PHP error reporting is set to E_ALL & ~E_NOTICE & ~E_STRICT; but if there is an fatal error (maybe an unterminated string, I found out (also on my local Apache), that there is NOTHING, no error, nothing.

    The SQL login data are correct, because the setup script creates the tables.
  • Options
    Has anyone any idea? Shall i post the php.ini or extracts of the Apache configuration?
  • Options
    Maybe a problem with php5.0.5. Can you try with php4 or php5.1.4 ?
  • Options
    MarkMark Vanilla Staff
    I think SirNot was onto it with mysql. I've seen this before and it is a real pain in the butt to figure out. I'd take a look at framework/framework.mysql.class.php. Go to the db connection method and do some testing there to see where it stops processing the page. I'm sure it has to do with a mysql connection failing and ALSO killing parsing of the page.
  • Options
    edited October 2006
    delete the file .htaccess (in the folder where the boards are installed), I am 99% sure its an apache error.
  • Options
    Thank's at all, but the only reason for this, was PHP 5.0.5. I updated to PHP 5.1.6 and now it works.
    Thank's a lot
  • Options
    Is there a significsng benefit to using PHP 5.x over 4.x (security- or speed-wise?)
This discussion has been closed.