Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Installation for Dummies

edited July 2005 in Vanilla 1.0 Help
Hello! I'm trying to set up a forum for our new website, and thought I'd give Vanilla a try. However, the whole process is a little confusing to me--I only know what about 1/3 of this stuff even means. I'm a writer, not a web designer. So, assuming it would be easier, I ran the automated installation. This is the error I get: " Vanilla Installation Wizard (Step 1 of 3)"); if ($WarningCollector->Count() > 0) { echo(" Oops. We came across some problems while checking your permissions... ".$WarningCollector->GetMessages()." " As if that's not bad enough (is it? I don't know, really), it goes on to say that I need to set up my permissions properly. I haven't a clue how to do this. It tells me how if I have a *nix server with command line access. Once again, I don't know what that means, but I'm pretty sure I don't have it. I can figure the rest out--hopefully--but those first two bits have me stuck. Do you think this stuff is over my head, or do you think I can get by with a little help? Any assistance is greatly appreciated.


  • lamentlament
    edited July 2005
    what FTP client are you using to upload the files to your server?

    try using Filezilla, then you can just right-click the directory and set the permissions without having to know command line stuff.
  • should be equally as easy to change the permissions if you've got cuteFTP... have a gander at
  • edited July 2005
    All right, awesome, I got Filezilla and changed all my permissions. But now I have a new problem. When I click the "Click here to check your permissions and proceed to the next step", I get an alert that says "550 No Such Directory". Wha? EDIT: Oh, and I'm still getting that warningcollector message.
  • MarkMark Vanilla Staff
    It sounds to me like you've either failed to upload all of the files properly (ie. your ftp program messed up and only uploaded partial files), or your version of php is older and messing up. Can we see it online?
  • Er, see what online? My version of PHP? For what it's worth, our host is GoDaddy, and they say that PHP is automatically enabled. I don't remember them saying anything about what version, though.
  • edited July 2005
    make a new plain text file and add into it

    <?php phpinfo(); ?>

    save it as phpinfo.php, upload it to your site and link to it here so people can have a look. (when you look at the file in a browser it will display all your php information, including which version).
  • MarkMark Vanilla Staff
    I was thinking it might be nice for us to get a link to your installer.php online so we can see the error for ourselves...
  • mark, whilst you're here, I think I've found a new bug. Block and unblock my comment above. the php code dissappears.
  • he's gonna blow *gets behind table
  • I have tried to do both, but succeeded only with one. PHP Info: Mark, I tried to get a link to the installer.php, but I honestly don't see how I could do that. As it is, the address is, but you won't be able to access that I think. Otherwise, I could copy and paste all of the output so you could view it. It's too much to post here on the forum, but I could probably just put it in a simple HTML file if you think it would help.
  • hehe
  • D'oh! Thanks, man. That also looks completely different than it does when I view it. I bet that was my problem all along. Let's find out...
  • So it was! Many thanks to everyone who responded and helped me along. It's always the simple solution that solves the problem, isn't it? ;) Thanks again everyone!
  • no problem :) have fun
This discussion has been closed.