Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Who's Online problem with Friendly URLs

edited December 2006 in Vanilla 1.0 Help
On a topic page, clicking the name of an online user takes you to http://www.domain.net/forum/discussion/9/topic-name/account.php?u=1 instead of http://www.domain.net/forum/discussions/account.php?u=1 I've seen this mentioned elsewhere but the solution was to edit the .htaccess - my .htaccess already has the suggested rules in it, but it still isn't working. Is there a way to hard-code the correct URL into the plugin? That worked for me with Spell Checker and it would seem to be the easy option.

Comments

  • Options
    Just to add: I have now disabled Friendly URLs as a few other plugins were failing because of them.
  • Options
    dan39dan39 New
    edited December 2006
    Those pesky page numbers show up in a bunch of places, and seem to cause issues. The RSS and ATOM feeds are experiencing similar problems. See Bug

    AND, I just noticed another problem with the RSS2 and ATOM feeds with Friendly URLs.

    If you subscribe to the RSS feed for this discussion and then click on the Title link (which should take you back to this discussion), it gives you http://lussumo.com/community/discussion/?DiscussionID=4490 as the URL -- which fails.
  • Options
    I had this same problem. Here's how you fix it. Go to line 163:
    $Panel->AddListItem($ListName, $Context->GetDefinition($name["Name"]), "account.php?u=" . $name["UserID"],NULL,"title=\"$TimePast\"");
    And change it to:
    $Panel->AddListItem($ListName, $Context->GetDefinition($name["Name"]), GetUrl($Context->Configuration, 'account.php', '', 'u', $name['UserID']), NULL, "title=\"$TimePast\"");
This discussion has been closed.