Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Attachments 2.0 and Vanilla 1.0.2

edited December 2006 in Vanilla 1.0 Help
I've just upgraded to Vanilla 1.0.2 and now I get this warning:

You have enabled Attachments 2.0, but it needs Vanilla 1.0.1! Your current Vanilla version is: 1.0.2
Everything seems to work fine despite this message. I suppose I'll have to disable it manually in the code.

Comments

  • Options
    If you want to get rid of this warning, go to line 60 of this extension's default.php file:
    if( APPLICATION_VERSION !== '1.0.2' ) {
    ...and replace '1.0.1' by '1.0.2'. Dumb and easy.
  • Options
    edited December 2006
    or replace it by:
    if (version_compare(APPLICATION_VERSION, '1.0.1', '<')) {
  • Options
    Yes, your solution is better than mine :)
  • Options
    edited December 2006
    The log-in page does not work now, for me. get the message: [code]Notice: Undefined variable: NoticeCollector in /home/warcr3/public_html/nightfusion/extensions/Attachments/default.php on line 61 Fatal error: Call to a member function AddNotice() on a non-object in /home/warcr3/public_html/nightfusion/extensions/Attachments/default.php on line 61[/code]
  • Options
    StashStash
    edited December 2006
    This works for me:
    if( APPLICATION_VERSION !== '1.0.2' ) {
    This doesn't! I still get the message when I use this...
    if (!version_compare(APPLICATION_VERSION, '1.0.1', '<')) { // don't use this it's wrongI realise that the second one is "The Right Way"TM, but it no workey for me :(

    Corrected as per Dinoboff's comment below!
    if (version_compare(APPLICATION_VERSION, '1.0.1', '<')) {
  • Options
    Sorry. Just take off the '!'. I edited my previous post.
  • Options
    Thanks Dinoboff, works a treat now :)
This discussion has been closed.