Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

'Whisper to' box too short

edited December 2006 in Vanilla 1.0 Help
I have users registering and logging in through Wordpress, so they are allowed to have long usernames. However, the text input box for 'Whisper your comments to' is too short to allow some of them. Is there any quick fix for this without editing the code? And if I do have to edit the code, which file would I find it in? Many thanks.

Comments

  • Options
    MarkMark Vanilla Staff
    edited December 2006
    Open up /path/to/vanilla/themes/vanilla/styles/default/vanilla.css and search for #WhisperUsername. You'll find the following line:

    #WhisperUsername, #WhisperAutoCompleteResults { width: 200px; }

    Change that width to whatever you want.
  • Options
    hi mark. thanks for the reply. that's not quite what i need though. the problem is that i can't actually get enough characters in the box. one of my usernames is 24 characters, for example.
  • Options
    edited December 2006
    The actual form has a MAXLENGTH attribute...

    It's in themes/comment_form.php
    <input id="WhisperUsername" name="WhisperUsername" type="text" value="'.$Comment->WhisperUsername.'" class="Whisper AutoCompleteInput" maxlength="20" />
    So change maxlength="20" to 30 or higher or remove the MAXLENGTH attribute altogether.

    Later:
    And as Mark says: You will likely want to do the same thing for /path/to/vanilla/themes/discussion_form.php
  • Options
    MarkMark Vanilla Staff
    Okay, find the file /path/to/vanilla/themes/comment_form.php and copy it to /path/to/vanilla/themes/vanilla/comment_form.php. Then open it up and look for this line:

    <input id="WhisperUsername" name="WhisperUsername" type="text" value="'.$Comment->WhisperUsername.'" class="Whisper AutoCompleteInput" maxlength="20" />

    Change the "maxlength" setting to something else and you should be good to go.

    You will likely want to do the same thing for /path/to/vanilla/themes/discussion_form.php
  • Options
    MarkMark Vanilla Staff
    Doh! 8 seconds late :)
This discussion has been closed.