Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Attachments 2.0 error message

peterkirnpeterkirn New
edited December 2006 in Vanilla 1.0 Help
Hi everyone, I keep getting the following nebulous error message when trying to post an attachment using the Attachments 2.0 add-on: "Some problems were encountered The requested discussion could not be found." I have chmod'ed the downloads folder and tried various routes to the uploads path on the server. Any idea what could cause this?


  • I think it's a bug when you create a new discussion and upload a file which is too large of doesn't have the required MIME type. Or does this occur at every upload?
  • Jazzman, I am hoping you can help me. I have the Attachment 1.4 installed on the new version of Vanilla 1.0.3. Could you tell me the difference between version 1.4 and 2.0? Are the basically the same? Anything that I need to be aware of if I upgrade to the 2.0 version? or suggestions? Thanks.
  • The main difference between Attachments 1.4 and 2.0 is the fact that 2.0 uses database tables to store attachment info, and 1.4 just uses the file system. Version 1.4 is slower, but more complete (as it has image display with thickbox and lightbox built-in). Attachments 2.0 is more extendible. I already created an addon for this extension "Inline images" which displays attachments as an image, rather than a download (when the attachment is an image file ofcourse :). I won't be working on Attachments 1.4, and in the future 2.0 will fully replace this extension.
  • Jazzman, Thanks, I actually have 2.0 installed I found out. When I click the Readme.html it shows version 1.4. I am having a problem with the popup "Remember to set Attachments Permissions for you and your users. You can do it at the Roles & Permissions page." continuing to show even after I have checked the permissions in the roles. any suggestions on how to reset this or disable it? Thanks.
  • There is a "Remove message" link in the notice :)
  • Jazzman, There is for sure. But if I click remove, and navigate around the page, there it is again....and again.....and just doesn't want to go away. So either it is not sensing that I have checked the roles and permissions, or something else is going on. I have edited, saved, and adjusted roles and permissions so many times to try to stop this from poping back up. Don't know what else to do. Maybe I am just not holding my mouth right.....when I do it. So suggestions appreciated. Thanks.
  • edited December 2006
    There is no check for roles and permissions. Is just a notice. If you can't remove it through clicking that link, you can disable it by manually adding this to your conf/settings.php file:
    $Configuration['ATTACHMENTS_NOTICE'] = '1';
  • Jazzman, Thanks, that worked.Thought I would share my experience with this. I found out that I had installed Version 2.0 over 1.4 so I had files from both. Please confirm that there should be only 4 files and one image folder in Version 2.0. Hope so....I deleted these other files that were from version 1.4 and replaced them with the files from the 2.0 download. Then I thought I would try to see if I went into each Role and Permission file and then verified each and then saved each one again. The message was still popping up. So I added your fix....and that corrected it. Thanks.
  • I keep getting this notice: "You have enabled Attachments 2.0, but it needs Vanilla 1.0.1! Your current Vanilla version is: 1.0.3" and now when I try to sign in, I get a PHP error: "Fatal error: Call to a member function on a non-object in /../../../extensions/Attachments/default.php on line 61" Any help would be appreciated.
  • I also get the message: 'You have enabled Attachments 2.0, but it needs Vanilla 1.0.1! Your current Vanilla version is: 1.0.3' Jazzman - are you working on an upgrade and if so, when do you think you might release it? Don't mean to sound pushy - just want to include a cool function..!
  • Please refer to the thread i linked to in my previous post. It wasnt an april fools or something...
  • LOL Mini :D
  • Still the same bug:

    See this post:

    I'm running Vanilla 1.0.1 with attachments 2.0. Installation worked, but when uploading a file, I get stuck:


    How do I fix it/ what have I done wrong?
  • I am having difficulty with attachments 2.1 on vanilla 1.1.9. The installation went fine. The directories were created on the first post with an attachment. However, when that post is clicked on, the web page is blank and viewing the source code shows a blank page as well. Unchecking attachment extension shows the original post without an attachment. The only other extension installed at this time is autolinks 1.5. Disabling that has no effect. Can anyone help with this?
  • hm,

    have you checked the options on our setting-page?
    Are the paths and so on ok there?

    can you copy the link to the attachment you click on.
    My you wanna post the link to your forum to let us check whats the problem.

    I don't have a real clue but I guess the link to the attachment is built wrong - so the link leads you to a non existing page -> blank
  • Thank you, vegano.

    The settings are correct in settings, the files are uploaded, and I can enter the url for the attachment in a web browser and it loads there.

    Once an attachment is added, the page is never built, just blank with no source code, so there is no link to the attachment visible.
  • Could it be the PHP version?
  • PHP Version 5.0.5

    Mysql Client API version 3.23.54
Sign In or Register to comment.