Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

BUG: "Too Long" editing error causes duplicate (new) topics

edited December 2006 in Vanilla 1.0 Help
Steps to reproduce bug:
  1. Start a new discussion
  2. Title and enter text however you want. Small amount.
  3. Post
  4. On new discussion, click "Edit" on the only comment (starter comment)
  5. Place FAR too much text in this. (We're looking to hit the "comments is N characters too long." error)
  6. On error page, reduce text to something under the text limit (say, "edited")
  7. Click save changes
  8. Move back to the discussions page, see duplicate topics now
It seems like you lose the "editing" attributes when you enter this scenario. Editing any comment other than the discussion opener does not display this issue.

Additional bug: when editing the opener post, if you try to edit multiple times unsuccessfully due to the message being too long, the system will stop putting your previous edit it. (Repeat the steps above, but try to "Save Changes" with too much text entered twice instead of just one time.)

Comments

  • Options
    I received a duplicate post that is similar to this. I installed the extension (DiceRoll) and was playing with the features. I read that you cannot change the number you rolled, so I tried anyway. When I edited the post, I removed the dice roll text and tried to save. I received an error stating that there was something wrong with the post. I added the dice roll back in #dice( 3d6 ) - everything worked (though the sum of the roll was different... which defeats the point), and I had a duplicate post. Sorry if this is posted in the wrong area - I just figured that the problems are related to the same thing (even though my problem is with an extension). I'll probably contact the author of the extension for official support, just giving you all a heads up. Take care! ~Achithyn
  • Options
    MarkMark Vanilla Staff
    Nice find - I'll get a fix in for the next revision :)

    *bookmarked*
  • Options
    Cool. :)
  • Options
    This happened to me as well, not sure it's a serious bug though.

    When it told me I had 122 words too many in my comment, I opened a new browser window, went to the Application Settings and increased Max characters in comments.

    I guess because I did this "behind its back" something went awry.
This discussion has been closed.