HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Feed Weirdness

edited July 2005 in Vanilla 1.0 Help

I just did the upgrade to 0.9.2 [from 0.9.1] and clicked thru to my feed page to find this:

FeedIntroduction

>

AvailableFeeds
AvailableFeedNotes

Any clue as to what's going on? I'm fairly certain that I followed the instructions to the letter - but it's not beyond me to have missed something.

Comments

  • I think it's connected to the language file. In some cases, the parameter name isn't replaced with the text from the language file. I don't know why, but this is happening to me in some other places as well.
  • lechlech Chicagoland
    That's perfectly normal, boogah. That only spares anyone accessing the page with a normal browser the hassle of wondering what the hell is going on. As well as telling them feeds aren't available in case you've turned them off.
  • Okay. So I guess I'll change the items by hand so people don't go getting confused.
  • lechlech Chicagoland
    Uhmmm, I'm simply saying you don't have to. If you bookmark that location and give it to a normal rss feed reader, it will do it's job and bypass that page all together.
  • MarkMark Vanilla Staff
    read the upgrade.html file that came in the zip.
  • MarkMark Vanilla Staff
    specifically:

    If you have altered your languages/English.php file, or created your own custom language file, rather than overwrite your customized language file with our new version, compare with our new version. All changes made to the language file are appended and documented at the end of the file. Make sure that any new codes are copied over into your existing language file.
  • lechlech Chicagoland
    mark. I also don't see an option in the settings anywhere that allows one to change the number of feeds :/
  • MarkMark Vanilla Staff
    It's manual at this point. go into your appg/settings.php file and change it there for now. I didn't have time to put it in the admin form.
  • lechlech Chicagoland
    edited July 2005
    Ahh, ok, right on. I was wondering whether that was left out or if I was going crazy. Thanks. Hopefully there will be a way to disable this feature as well in the future.
  • Crap! I knew I missed something. Sorry Mark, et al.
  • Hrm, that's odd. I just realized that the feeds don't seem to translate markdown to HTML. Any links, etc. look like their markdown counterparts.
  • lechlech Chicagoland
    It's a new feature, No doubt mark hasn't considered all the extension implications of it yet. Just be lucky it works for the meantime. But yes, markdown should be converted or something.
  • Yeah big up for just adding a feed in the first place - it's sweet!
  • MarkMark Vanilla Staff
    There is a very big hurdle to jump in order to allow for html in the feeds. I haven't figured out a way to get over it yet. For now it's just put through a basic formatting so it doesn't break. I'll have to think of a way to handle the formatters.
  • lechlech Chicagoland
    I think one easy way of doing it would be to take the threadview output like we see it here. And just shove it back down text which should normalize it all to basic text. Break apart ordered lists and such to include some reasonable formatting and you're golden.
This discussion has been closed.